# CVE-2026-23897: Apollo Server is vulnerable to denial of service with `startStandaloneServer`

> Attackers can cause denial of service in Apollo Server standalone mode via crafted request bodies with exotic encodings.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Feb 2026
- **Updated:** 4 Feb 2026
- **Also known as:** GHSA-mp6q-xf9x-fwf7, ROOT-APP-NPM-CVE-2026-23897

## What is CVE-2026-23897?

CVE-2026-23897 is a high-severity denial of service vulnerability in apollographql apollo-server, published on 4 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apollo Server is an open-source, spec-compliant GraphQL server that's compatible with any GraphQL client, including Apollo Client. In versions from 2.0.0 to 3.13.0, 4.2.0 to before 4.13.0, and 5.0.0 to before 5.4.0, the default configuration of startStandaloneServer from @apollo/server/standalone is vulnerable to denial of service (DoS) attacks through specially crafted request bodies with exotic character set encodings. This issue does not affect users that use @apollo/server as a dependency for integration packages, like @as-integrations/express5 or @as-integrations/next, only direct usage of startStandaloneServer.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-23897?

6 open source packages ship an affected version, including apollo-server and @apollo/server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apollo-server` | npm | From 2.0.0 to 3.13.0 | None |
| `apollo-server` | npm | From 2.0.0 to 3.13.0 | None |
| `@apollo/server` | npm | From 4.2.0 | 4.13.0 |
| `@apollo/server` | npm | From 4.2.0 | 4.13.0 |
| `@apollo/server` | npm | From 5.0.0 | 5.4.0 |
| `@apollo/server` | npm | From 5.0.0 | 5.4.0 |

Products: Apollographql Apollo Server.

## How do I fix CVE-2026-23897?

Upgrade to a fixed version.

## Is CVE-2026-23897 being exploited?

There is no known exploitation of CVE-2026-23897 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23897 and fix it if it is affected.

What it is: CVE-2026-23897 is a high-severity denial of service vulnerability in apollographql apollo-server, published on 4 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-23897 in the wild and no public exploit code.

Affected packages and fixed versions:
- apollo-server (npm): affected from 2.0.0 up to 3.13.0; no fix listed
- apollo-server (npm): affected from 2.0.0 up to 3.13.0; no fix listed
- @apollo/server (npm): affected from 4.2.0; fixed in 4.13.0
- @apollo/server (npm): affected from 4.2.0; fixed in 4.13.0
- @apollo/server (npm): affected from 5.0.0; fixed in 5.4.0
- @apollo/server (npm): affected from 5.0.0; fixed in 5.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23897/ (Markdown: https://insights.sbomify.com/CVE-2026-23897/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23897
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23897
- OSV: https://osv.dev/vulnerability/CVE-2026-23897

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23897/
Summaries are generated and may contain mistakes; the official description above is the record.
