# CVE-2026-23901: Apache Shiro: Brute force attack possible to determine valid user names

> Attackers can enumerate valid usernames via timing discrepancies in Apache Shiro, facilitating targeted brute-force attacks.

- **Severity:** Low 1.0 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:A/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N/S:N/AU:Y/R:A/V:C/RE:L/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Feb 2026
- **Updated:** 10 Feb 2026
- **Also known as:** CLEANSTART-2026-WY81634, CLEANSTART-2026-XU58754, DEBIAN-CVE-2026-23901, ECHO-d58c-d10e-42b1, GHSA-c4qc-4q9p-m9q9, MINI-2xmq-qc58-x2hx, MINI-42fc-w88x-wc5p, MINI-593v-p9qc-8hf9, MINI-5prg-86fp-vw6w, MINI-966v-wrrc-438g, MINI-c77g-fxcw-x25q, MINI-cpfr-cm94-r87v, MINI-g9x4-5mx4-5rr9, MINI-gg5p-ffh8-h37h, MINI-hhqv-mx6h-pmx8, MINI-hw8j-88g7-x6qr, MINI-jrjg-p9wv-mh8g, MINI-mxgc-c6xc-2669, MINI-pqp2-239g-37jv, MINI-qp29-8qw4-jp76, MINI-rf84-vc2x-fjwr, MINI-w9fc-xhgx-ppx6, MINI-xm2p-xphr-q4fw, MINI-xwp9-c2rf-58jv, UBUNTU-CVE-2026-23901

## What is CVE-2026-23901?

CVE-2026-23901 is a low-severity vulnerability in Apache Shiro, published on 10 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Observable Timing Discrepancy vulnerability in Apache Shiro.

This issue affects Apache Shiro: from 1.*, 2.* before 2.0.7.

Users are recommended to upgrade to version 2.0.7 or later, which fixes the issue.

Prior to Shiro 2.0.7, code paths for non-existent vs. existing users are different enough,
that a brute-force attack may be able to tell, by timing the requests only, determine if
the request failed because of a non-existent user vs. wrong password.

The most likely attack vector is a local attack only.
Shiro security model  https://shiro.apache.org/security-model.html#username_enumeration  discusses this as well.

Typically, brute force attack can be mitigated at the infrastructure level.

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2026-23901?

2 open source packages ship an affected version, including org.apache.shiro:shiro-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.shiro:shiro-core` | Maven | All versions | 2.1.0 |
| `org.apache.shiro:shiro-core` | Maven | All versions | 2.1.0 |

Products: Apache Shiro.

## How do I fix CVE-2026-23901?

Upgrade org.apache.shiro:shiro-core to 2.1.0 or later.

## Is CVE-2026-23901 being exploited?

There is no known exploitation of CVE-2026-23901 in the wild and no public exploit code.

## Other vulnerabilities in Apache Shiro

- [CVE-2023-34478](https://insights.sbomify.com/CVE-2023-34478/): Path Traversal in Apache Shiro (critical 9.8)
- [CVE-2022-40664](https://insights.sbomify.com/CVE-2022-40664/): Authentication Bypass Vulnerability in Shiro when forwarding or including via RequestDispatcher (critical 9.8)
- [CVE-2022-32532](https://insights.sbomify.com/CVE-2022-32532/): Authentication Bypass Vulnerability (critical 9.8)
- [CVE-2021-41303](https://insights.sbomify.com/CVE-2021-41303/): Apache Shiro vulnerable to a specially crafted HTTP request causing an authentication bypass (critical 9.8)
- [CVE-2020-17523](https://insights.sbomify.com/CVE-2020-17523/): Authentication bypass in Apache Shiro (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23901 and fix it if it is affected.

What it is: CVE-2026-23901 is a low-severity vulnerability in Apache Shiro, published on 10 Feb 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-23901 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.shiro:shiro-core (Maven): affected all versions; fixed in 2.1.0
- org.apache.shiro:shiro-core (Maven): affected all versions; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23901/ (Markdown: https://insights.sbomify.com/CVE-2026-23901/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23901
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23901
- OSV: https://osv.dev/vulnerability/CVE-2026-23901

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23901/
Summaries are generated and may contain mistakes; the official description above is the record.
