# CVE-2026-23902: Apache DolphinScheduler: Users are able to use tenants that are not defined on the platform during workflow execution.

> Authenticated users can execute workflows using undefined tenants, bypassing intended tenant isolation controls.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 24 Apr 2026
- **Also known as:** GHSA-72mv-wwvm-vgp5

## What is CVE-2026-23902?

CVE-2026-23902 is a high-severity missing authorization vulnerability in Apache DolphinScheduler, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incorrect Authorization vulnerability in Apache DolphinScheduler allows authenticated users with system login permissions to use tenants that are not defined on the platform during workflow execution.

This issue affects Apache DolphinScheduler versions prior to 3.4.1. 

Users are recommended to upgrade to version 3.4.1, which fixes this issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-23902?

2 open source packages ship an affected version, including org.apache.dolphinscheduler:dolphinscheduler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.dolphinscheduler:dolphinscheduler` | Maven | All versions | 3.4.1 |
| `org.apache.dolphinscheduler:dolphinscheduler` | Maven | All versions | 3.4.1 |

Products: Apache Dolphinscheduler.

## How do I fix CVE-2026-23902?

Upgrade org.apache.dolphinscheduler:dolphinscheduler to 3.4.1 or later.

## Is CVE-2026-23902 being exploited?

There is no known exploitation of CVE-2026-23902 in the wild and no public exploit code.

## Other vulnerabilities in Apache DolphinScheduler

- [CVE-2024-43166](https://insights.sbomify.com/CVE-2024-43166/): Apache DolphinScheduler Incorrect Default Permissions Vulnerability (critical 9.8)
- [CVE-2024-43202](https://insights.sbomify.com/CVE-2024-43202/): Apache DolphinScheduler: Remote Code Execution Vulnerability (critical 9.8)
- [CVE-2023-49109](https://insights.sbomify.com/CVE-2023-49109/): Remote Code Execution in Apache Dolphinscheduler (critical 9.8)
- [CVE-2022-45875](https://insights.sbomify.com/CVE-2022-45875/): Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin (critical 9.8)
- [CVE-2022-45462](https://insights.sbomify.com/CVE-2022-45462/): Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23902 and fix it if it is affected.

What it is: CVE-2026-23902 is a high-severity missing authorization vulnerability in Apache DolphinScheduler, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-23902 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.dolphinscheduler:dolphinscheduler (Maven): affected all versions; fixed in 3.4.1
- org.apache.dolphinscheduler:dolphinscheduler (Maven): affected all versions; fixed in 3.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23902/ (Markdown: https://insights.sbomify.com/CVE-2026-23902/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23902
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23902
- OSV: https://osv.dev/vulnerability/CVE-2026-23902

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23902/
Summaries are generated and may contain mistakes; the official description above is the record.
