# CVE-2026-23906: Apache Druid: Authentication Bypass via LDAP Anonymous Bind

> Attackers bypass authentication in Apache Druid by exploiting LDAP anonymous bind configurations, gaining unauthorized access to data and administrative interfaces.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Feb 2026
- **Updated:** 12 Feb 2026
- **Also known as:** GHSA-q672-hfc7-g833

## What is CVE-2026-23906?

CVE-2026-23906 is a critical authentication bypass vulnerability in Apache Druid, published on 10 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Affected Products and Versions
  *  Apache Druid
  *  Affected Versions: 0.17.0 through 35.x (all versions prior to 36.0.0)
  *  Prerequisites:  *  druid-basic-security extension enabled
  *  LDAP authenticator configured
  *  Underlying LDAP server permits anonymous bind                                                                                                                                                   

Vulnerability Description

An authentication bypass vulnerability exists in Apache Druid when using the druid-basic-security extension with LDAP authentication. If the underlying LDAP server is configured to allow anonymous
binds, an attacker can bypass authentication by providing an existing username with an empty password. This allows unauthorized access to otherwise restricted Druid resources without valid credentials.

The vulnerability stems from improper validation of LDAP authentication responses when anonymous binds are permitted, effectively treating anonymous bind success as valid user authentication. 

Impact

A remote, unauthenticated attacker can:
  *  Gain unauthorized access to the Apache Druid cluster
  *  Access sensitive data stored in Druid datasources
  *  Execute queries and potentially manipulate data
  *  Access administrative interfaces if the bypassed account has elevated privileges
  *  Completely compromise the confidentiality, integrity, and availability of the Druid deployment                                                                                                                                                                                    

Mitigation
 
Immediate Mitigation (No Druid Upgrade Required):                                                                                                                                                    
  *  Disable anonymous bind on your LDAP server. This prevents the vulnerability from being exploitable and is the recommended immediate action.

Resolution
  *  Upgrade Apache Druid to version 36.0.0 or later, which includes fixes to properly reject anonymous LDAP bind attempts.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-23906?

2 open source packages ship an affected version, including org.apache.druid.extensions:druid-basic-security. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.druid.extensions:druid-basic-security` | Maven | From 0.17.0 | 36.0.0 |
| `org.apache.druid.extensions:druid-basic-security` | Maven | From 0.17.0 | 36.0.0 |

Products: Apache Druid.

## How do I fix CVE-2026-23906?

Upgrade org.apache.druid.extensions:druid-basic-security to 36.0.0 or later.

## Is CVE-2026-23906 being exploited?

There is no known exploitation of CVE-2026-23906 in the wild and no public exploit code.

## Other vulnerabilities in Apache Druid

- [CVE-2025-59390](https://insights.sbomify.com/CVE-2025-59390/): Apache Druid: Kerberos authenticaton chooses a cryptographically unsecure secret if not configured explicitly. (critical 9.8)
- [CVE-2021-26919](https://insights.sbomify.com/CVE-2021-26919/): Apache Druid Authenticated users can execute arbitrary code from malicious MySQL database systems. (high 8.8)
- [CVE-2021-25646](https://insights.sbomify.com/CVE-2021-25646/): Authenticated users can override system configurations in their requests which allows them to execute arbitrary code. (high 8.8)
- [CVE-2024-45537](https://insights.sbomify.com/CVE-2024-45537/): Apache Druid: Users can provide MySQL JDBC properties not on allow list (medium 6.5)
- [CVE-2021-36749](https://insights.sbomify.com/CVE-2021-36749/): Druid ingestion system Authenticated users can read data from other sources than intended (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23906 and fix it if it is affected.

What it is: CVE-2026-23906 is a critical authentication bypass vulnerability in Apache Druid, published on 10 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-23906 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.druid.extensions:druid-basic-security (Maven): affected from 0.17.0; fixed in 36.0.0
- org.apache.druid.extensions:druid-basic-security (Maven): affected from 0.17.0; fixed in 36.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23906/ (Markdown: https://insights.sbomify.com/CVE-2026-23906/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23906
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23906
- OSV: https://osv.dev/vulnerability/CVE-2026-23906

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23906/
Summaries are generated and may contain mistakes; the official description above is the record.
