CVE-2026-2391 qs's arrayLimit bypass in comma parsing allows denial of service

Medium 6.3 Published Updated

Attackers can cause denial of service via memory exhaustion by bypassing array limits in comma-separated parsing when the comma option is enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-2391?

CVE-2026-2391 is a medium-severity denial of service vulnerability in qs_project:qs, published on 12 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

### Summary The `arrayLimit` option in qs does not enforce limits for comma-separated values when `comma: true` is enabled, allowing attackers to cause denial-of-service via memory exhaustion. This is a bypass of the array limit enforcement, similar to the bracket notation bypass addressed in GHSA-6rw7-vpxm-498p (CVE-2025-15284).

### Details When the `comma` option is set to `true` (not the default, but configurable in applications), qs allows parsing comma-separated strings as arrays (e.g., `?param=a,b,c` becomes `['a', 'b', 'c']`). However, the limit check for `arrayLimit` (default: 20) and the optional throwOnLimitExceeded occur after the comma-handling logic in `parseArrayValue`, enabling a bypass. This permits creation of arbitrarily large arrays from a single parameter, leading to excessive memory allocation.

**Vulnerable code** (lib/parse.js: lines ~40-50): ```js if (val && typeof val === 'string' && options.comma && val.indexOf(',') > -1) {     return val.split(','); }

if (options.throwOnLimitExceeded && currentArrayLength >= options.arrayLimit) {     throw new RangeError('Array limit exceeded. Only ' + options.arrayLimit + ' element' + (options.arrayLimit === 1 ? '' : 's') + ' allowed in an array.'); }

return val; ``` The `split(',')` returns the array immediately, skipping the subsequent limit check. Downstream merging via `utils.combine` does not prevent allocation, even if it marks overflows for sparse arrays.This discrepancy allows attackers to send a single parameter with millions of commas (e.g., `?param=,,,,,,,,...`), allocating massive arrays in memory without triggering limits. It bypasses the intent of `arrayLimit`, which is enforced correctly for indexed (`a[0]=`) and bracket (`a[]=`) notations (the latter fixed in v6.14.1 per GHSA-6rw7-vpxm-498p).

### PoC **Test 1 - Basic bypass:** ``` npm install qs ```

```js const qs = require('qs');

const payload = 'a=' + ','.repeat(25); // 26 elements after split (bypasses arrayLimit: 5) const options = { comma: true, arrayLimit: 5, throwOnLimitExceeded: true };

try {   const result = qs.parse(payload, options);   console.log(result.a.length); // Outputs: 26 (bypass successful) } catch (e) {   console.log('Limit enforced:', e.message); // Not thrown } ``` **Configuration:** - `comma: true` - `arrayLimit: 5` - `throwOnLimitExceeded: true`

Expected: Throws "Array limit exceeded" error. Actual: Parses successfully, creating an array of length 26.

### Impact Denial of Service (DoS) via memory exhaustion.

Weakness: CWE-20

Which versions are affected by CVE-2026-2391?

2 open source packages ship an affected version, including qs. It affects 1 product.

PackageAffectedFixed in
qs npmFrom 6.7.06.14.2
qs npmFrom 6.7.06.14.2

Products include Qs Project Qs.

How do I fix CVE-2026-2391?

Upgrade qs to 6.14.2 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-2391 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-2391 exists.

Sources

Also known as AZL-77594, AZL-77597, AZL-77601, AZL-77616, CLEANSTART-2026-BV94239, CLEANSTART-2026-FY63723 and 29 more.

Is CVE-2026-2391 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free