CVE-2026-23918 Apache HTTP Server: http2: double free and possible RCE on early reset

High 8.8 Published Updated

Attackers can trigger a double free in the HTTP/2 module, potentially leading to remote code execution or denial of service on Apache HTTP Server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-23918?

CVE-2026-23918 is a high-severity use after free vulnerability in Apache Http Server, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Double Free and possible RCE vulnerability in Apache HTTP Server with the HTTP/2 protocol.

This issue affects Apache HTTP Server: 2.4.66.

Users are recommended to upgrade to version 2.4.67, which fixes the issue.

Weakness: CWE-1341, CWE-415

Which versions are affected by CVE-2026-23918?

1 open source package ship an affected version, including apache. It affects 1 product.

PackageAffectedFixed in
apache BitnamiFrom 2.4.662.4.67

Products include Apache Http Server.

How do I fix CVE-2026-23918?

Upgrade apache to 2.4.67 or later.

Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.

Is CVE-2026-23918 being exploited?

There is no known exploitation of CVE-2026-23918 in the wild and no public exploit code.

Public exploit code: 1 Exploit-DB entry and 15 proofs of concept on GitHub.

All Apache Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2026-23918, AZL-86004, BELL-CVE-2026-23918, BIT-apache-2026-23918, CLSA-2026-1778054005, CLSA-2026-1778070287 and 5 more.

Is CVE-2026-23918 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free