# CVE-2026-23918: Apache HTTP Server: http2: double free and possible RCE on early reset

> Attackers can trigger a double free in the HTTP/2 module, potentially leading to remote code execution or denial of service on Apache HTTP Server.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 15 Jul 2026
- **Also known as:** ALPINE-CVE-2026-23918, AZL-86004, BELL-CVE-2026-23918, BIT-apache-2026-23918, CLSA-2026-1778054005, CLSA-2026-1778070287, CLSA-2026-1778107205, DEBIAN-CVE-2026-23918, GHSA-p8fm-9c82-pw4g, MINI-6g43-93qq-h8px, UBUNTU-CVE-2026-23918

## What is CVE-2026-23918?

CVE-2026-23918 is a high-severity use after free vulnerability in Apache Http Server, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Double Free and possible RCE vulnerability in Apache HTTP Server with the HTTP/2 protocol.

This issue affects Apache HTTP Server: 2.4.66.

Users are recommended to upgrade to version 2.4.67, which fixes the issue.

Weakness: CWE-1341 (Multiple Releases of Same Resource or Handle), CWE-415 (Double Free)

## Which versions are affected by CVE-2026-23918?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.66 | 2.4.67 |

Products: Apache Http Server.

## How do I fix CVE-2026-23918?

Upgrade apache to 2.4.67 or later.

## Is CVE-2026-23918 being exploited?

There is no known exploitation of CVE-2026-23918 in the wild and no public exploit code.

Public exploit code:

- Double-free in Apache httpd mod_http2 stream cleanup leading to pre-auth RCE. (github_poc): https://github.com/striga-ai/CVE-2026-23918
- Proof-of-Concept exploit for CVE-2026-23918 (Apache mod_http2 double-free). Features multi-mode DoS (Rapid-RST, Slow-Drip) and passive RCE/vulnerability detection for Apache 2.4.66. (github_poc): https://github.com/xeloxa/CVE-2026-23918-Apache-H2-PoC
- Apache HTTP/2 double-free vulnerability PoC (CVE-2026-23918) (github_poc): https://github.com/rhasan-com/CVE-2026-23918
- Elite reconnaissance script for auditing Apache's HTTP/2 stack against memory corruption (CVE-2026-23918). Features ALPN protocol forcing and monochrome dashboard intelligence. Built for Blue Teams and Security Researchers. (github_poc): https://github.com/qassam-315/CVE-2026-23918-Elite-Auditor
- This repository contains a Proof of Concept (PoC) demonstrating the Double Free vulnerability (CVE-2026-23918) in Apache HTTP Server 2.4.66 `mod_http2`. (github_poc): https://github.com/12lie20/CVE-2026-23918-test
- This is a proactive tool for security auditing. For your GitHub repository, you’ll want a description that highlights its safety (non-intrusive) and its specific utility for system administrators. (github_poc): https://github.com/hackervlogofficial/CVE-2026-23918

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23918 and fix it if it is affected.

What it is: CVE-2026-23918 is a high-severity use after free vulnerability in Apache Http Server, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-23918 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.66; fixed in 2.4.67

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23918/ (Markdown: https://insights.sbomify.com/CVE-2026-23918/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23918
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23918
- OSV: https://osv.dev/vulnerability/CVE-2026-23918

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23918/
Summaries are generated and may contain mistakes; the official description above is the record.
