# CVE-2026-23946: Tendenci has Authenticated Remote Code Execution via Pickle Deserialization

> Authenticated staff users can execute arbitrary code via unsafe pickle deserialization in the optional Helpdesk module.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jan 2026
- **Updated:** 22 Jan 2026
- **Also known as:** GHSA-339m-4qw5-j2g3, PYSEC-2026-1950

## What is CVE-2026-23946?

CVE-2026-23946 is a medium-severity unsafe deserialization vulnerability in tendenci, published on 22 Jan 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Tendenci is an open source content management system built for non-profits, associations and cause-based sites. Versions 15.3.11 and below include a critical deserialization vulnerability in the Helpdesk module (which is not enabled by default). This vulnerability allows Remote Code Execution (RCE) by an authenticated user with staff security level due to using Python's pickle module in helpdesk /reports/. The original CVE-2020-14942 was incompletely patched. While ticket_list() was fixed to use safe JSON deserialization, the run_report() function still uses unsafe pickle.loads(). The impact is limited to the permissions of the user running the application, typically www-data, which generally lacks write (except for upload directories) and execute permissions. This issue has been fixed in version 15.3.12.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-23946?

3 open source packages ship an affected version, including tendenci. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tendenci` | PyPI | All versions | 15.3.12 |
| `tendenci` | PyPI | All versions | 15.3.12 |
| `tendenci` | PyPI | All versions | 15.3.12 |

Products: Tendenci Tendenci.

## How do I fix CVE-2026-23946?

Upgrade tendenci to 15.3.12 or later.

## Is CVE-2026-23946 being exploited?

There is no known exploitation of CVE-2026-23946 in the wild and no public exploit code.

## Other vulnerabilities in tendenci

- [CVE-2020-14942](https://insights.sbomify.com/CVE-2020-14942/): Deserialization of Untrusted Data in Tendenci (critical 9.8)
- [CVE-2025-70959](https://insights.sbomify.com/CVE-2025-70959/): Tendenci CMS Contains a Cross-site Scripting Vulnerability in its Jobs Module (medium 5.4)
- [CVE-2025-70960](https://insights.sbomify.com/CVE-2025-70960/): Tendenci CMS contains a stored Cross-site Scripting (XSS) vulnerability in the Forums module (medium 5.4)
- [CVE-2020-36962](https://insights.sbomify.com/CVE-2020-36962/): Tendenci 12.3.1 - CSV/ Formula Injection (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23946 and fix it if it is affected.

What it is: CVE-2026-23946 is a medium-severity unsafe deserialization vulnerability in tendenci, published on 22 Jan 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-23946 in the wild and no public exploit code.

Affected packages and fixed versions:
- tendenci (PyPI): affected all versions; fixed in 15.3.12
- tendenci (PyPI): affected all versions; fixed in 15.3.12
- tendenci (PyPI): affected all versions; fixed in 15.3.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23946/ (Markdown: https://insights.sbomify.com/CVE-2026-23946/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23946
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23946
- OSV: https://osv.dev/vulnerability/CVE-2026-23946

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23946/
Summaries are generated and may contain mistakes; the official description above is the record.
