CVE-2026-23947 Orval MCP client is vulnerable to code injection via unsanitized x-enum-descriptions in enum generation
Attackers can inject arbitrary code into generated clients via malicious OpenAPI specs, leading to code execution in consuming environments.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-23947?
CVE-2026-23947 is a critical code injection vulnerability in orval-labs orval, published on 20 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Orval generates type-safe JS clients (TypeScript) from any valid OpenAPI v3 or Swagger v2 specification. Versions prior to 7.19.0 until 8.0.2 are vulnerable to arbitrary code execution in environments consuming generated clients. This issue is similar in nature to CVE-2026-22785, but affects a different code path in @orval/core that was not addressed by CVE-2026-22785's fix. The vulnerability allows untrusted OpenAPI specifications to inject arbitrary TypeScript/JavaScript code into generated clients via the x-enumDescriptions field, which is embedded without proper escaping in getEnumImplementation(). I have confirmed that the injection occurs during const enum generation and results in executable code within the generated schema files. Orval 7.19.0 and 8.0.2 contain a fix for the issue.
Which versions are affected by CVE-2026-23947?
4 open source packages ship an affected version, including @orval/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
@orval/core npm | All versions | 7.19.0 |
@orval/core npm | All versions | 7.19.0 |
@orval/core npm | From 8.0.0-rc.0 | 8.0.2 |
@orval/core npm | From 8.0.0-rc.0 | 8.0.2 |
Products include Orval Orval.
How do I fix CVE-2026-23947?
Upgrade @orval/core to a fixed version for your release line: 7.19.0 or 8.0.2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-23947 being exploited?
There is no known exploitation of CVE-2026-23947 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in orval-labs orval
Sources
Also known as GHSA-h526-wf6g-67jv.