{"answers":{"affected":"4 open source packages ship an affected version, including @orval/core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-23947 in the wild and no public exploit code.","fix":"Upgrade @orval/core to a fixed version for your release line: 7.19.0 or 8.0.2.","what":"CVE-2026-23947 is a critical code injection vulnerability in orval-labs orval, published on 20 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-23947 and fix it if it is affected.\n\nWhat it is: CVE-2026-23947 is a critical code injection vulnerability in orval-labs orval, published on 20 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-23947 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @orval/core (npm): affected all versions; fixed in 7.19.0\n- @orval/core (npm): affected all versions; fixed in 7.19.0\n- @orval/core (npm): affected from 8.0.0-rc.0; fixed in 8.0.2\n- @orval/core (npm): affected from 8.0.0-rc.0; fixed in 8.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-23947/ (Markdown: https://insights.sbomify.com/CVE-2026-23947/index.md)","id":"CVE-2026-23947","markdown":"https://insights.sbomify.com/CVE-2026-23947/index.md","name":"CVE-2026-23947","record":{"aliases":["GHSA-h526-wf6g-67jv"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenAPI client generator","requires_auth":"none","summary":"Attackers can inject arbitrary code into generated clients via malicious OpenAPI specs, leading to code execution in consuming environments.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"orval","vendor":"orval"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"},{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"Orval generates type-safe JS clients (TypeScript) from any valid OpenAPI v3 or Swagger v2 specification. Versions prior to 7.19.0 until 8.0.2 are vulnerable to arbitrary code execution in environments consuming generated clients. This issue is similar in nature to CVE-2026-22785, but affects a different code path in @orval/core that was not addressed by CVE-2026-22785's fix. The vulnerability allows untrusted OpenAPI specifications to inject arbitrary TypeScript/JavaScript code into generated clients via the x-enumDescriptions field, which is embedded without proper escaping in getEnumImplementation(). I have confirmed that the injection occurs during const enum generation and results in executable code within the generated schema files. Orval 7.19.0 and 8.0.2 contain a fix for the issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2026-01-21","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-01-21T07:48:22Z","kind":"github_poc","ref":"https://github.com/boroeurnprach/CVE-2026-23947-PoC","stars":0,"title":"CVE-2026-23947 - Orval Arbitrary Code Execution"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Orval MCP client is vulnerable to code injection via unsanitized x-enum-descriptions in enum generation","id":"CVE-2026-23947","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"FreeRDP has a NULL Pointer Dereference in rdp_write_logon_info_v2()","id":"CVE-2026-23948"},"packages":[{"ecosystem":"npm","fixed":["7.19.0"],"introduced":["0"],"last_affected":[],"package":"@orval/core","purl":null,"source":"GHSA-h526-wf6g-67jv"},{"ecosystem":"npm","fixed":["7.19.0"],"introduced":["0"],"last_affected":[],"package":"@orval/core","purl":"pkg:npm/%40orval/core","source":"GHSA-h526-wf6g-67jv"},{"ecosystem":"npm","fixed":["8.0.2"],"introduced":["8.0.0-rc.0"],"last_affected":[],"package":"@orval/core","purl":null,"source":"GHSA-h526-wf6g-67jv"},{"ecosystem":"npm","fixed":["8.0.2"],"introduced":["8.0.0-rc.0"],"last_affected":[],"package":"@orval/core","purl":"pkg:npm/%40orval/core","source":"GHSA-h526-wf6g-67jv"}],"prev":{"headline":"Tendenci has Authenticated Remote Code Execution via Pickle Deserialization","id":"CVE-2026-23946"},"products":["orval"],"published":"2026-01-20","related":[{"cvss_score":9.3,"headline":"Orval has a code injection via unsanitized x-enum-descriptions uing JS comments","id":"CVE-2026-25141","kev_date_added":null,"published":"2026-01-30"},{"cvss_score":9.3,"headline":"orval MCP client is vulnerable to a code injection attack.","id":"CVE-2026-22785","kev_date_added":null,"published":"2026-01-12"},{"cvss_score":7.7,"headline":"Orval Mock Generation Code Injection via const","id":"CVE-2026-24132","kev_date_added":null,"published":"2026-01-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-21","vendors":["orval-labs"]},"summary":"Attackers can inject arbitrary code into generated clients via malicious OpenAPI specs, leading to code execution in consuming environments.","url":"https://insights.sbomify.com/CVE-2026-23947/"}