# CVE-2026-23949: jaraco.context Has a Path Traversal Vulnerability

> Attackers can extract files outside the intended directory via malicious tar archives in jaraco.context, potentially reading or modifying sensitive files.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jan 2026
- **Updated:** 20 Jan 2026
- **Also known as:** CLEANSTART-2026-JO48164, CLEANSTART-2026-YQ75311, CLSA-2026-1772496730, DEBIAN-CVE-2026-23949, ECHO-4dea-2475-6d75, GHSA-58pv-8j8x-9vj2, MINI-472w-hwcg-5jr3, MINI-6f37-9jxj-g3jg, MINI-86w9-8p7j-49rm, MINI-gv35-wwc2-c5m6, MINI-j5fh-p289-wpqj, MINI-j67c-6q7q-ggwx, MINI-q8mh-rxv5-rp93, MINI-w25h-jcq3-xccw, PYSEC-2026-1469, ROOT-APP-PYPI-CVE-2026-23949, ROOT-APP-PYPI-GHSA-58pv-8j8x-9vj2, ROOT-OS-DEBIAN-13-CVE-2026-23949, SUSE-SU-2026:20139-1, UBUNTU-CVE-2026-23949, USN-7979-1, openSUSE-SU-2026:10077-1, openSUSE-SU-2026:20095-1

## What is CVE-2026-23949?

CVE-2026-23949 is a high-severity path traversal vulnerability in jaraco.context, published on 20 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jaraco.context, an open-source software package that provides some useful decorators and context managers, has a Zip Slip path traversal vulnerability in the `jaraco.context.tarball()` function starting in version 5.2.0 and prior to version 6.1.0. The vulnerability may allow attackers to extract files outside the intended extraction directory when malicious tar archives are processed. The strip_first_component filter splits the path on the first `/` and extracts the second component, while allowing `../` sequences. Paths like `dummy_dir/../../etc/passwd` become `../../etc/passwd`. Note that this suffers from a nested tarball attack as well with multi-level tar files such as `dummy_dir/inner.tar.gz`, where the inner.tar.gz includes a traversal `dummy_dir/../../config/.env` that also gets translated to `../../config/.env`. Version 6.1.0 contains a patch for the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-23949?

3 open source packages ship an affected version, including jaraco.context and jaraco-context. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jaraco.context` | PyPI | From 5.2.0 | 6.1.0 |
| `jaraco-context` | PyPI | From 5.2.0 | 6.1.0 |
| `jaraco-context` | PyPI | From 5.2.0 | 6.1.0 |
| `python-jaraco.context` | SUSE:Linux Enterprise Server 16.0 | All versions | 5.3.0-160000.3.1 |
| `python-jaraco.context` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 5.3.0-160000.3.1 |
| `python-jaraco.context` | openSUSE:Leap 16.0 | All versions | 5.3.0-160000.3.1 |
| `python-jaraco.context` | openSUSE:Tumbleweed | All versions | 6.1.0-1.1 |

Products: Jaraco Jaraco.context.

## How do I fix CVE-2026-23949?

Upgrade jaraco.context to 6.1.0 or later.

## Is CVE-2026-23949 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23949 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23949 and fix it if it is affected.

What it is: CVE-2026-23949 is a high-severity path traversal vulnerability in jaraco.context, published on 20 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23949 exists.

Affected packages and fixed versions:
- jaraco.context (PyPI): affected from 5.2.0; fixed in 6.1.0
- jaraco-context (PyPI): affected from 5.2.0; fixed in 6.1.0
- jaraco-context (PyPI): affected from 5.2.0; fixed in 6.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23949/ (Markdown: https://insights.sbomify.com/CVE-2026-23949/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23949
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23949
- OSV: https://osv.dev/vulnerability/CVE-2026-23949

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23949/
Summaries are generated and may contain mistakes; the official description above is the record.
