CVE-2026-23953 Incus container environment configuration newline injection
A user with container launch privileges can inject newlines into environment variables to execute arbitrary commands on the host via lifecycle hooks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-23953?
CVE-2026-23953 is a high-severity code injection vulnerability in lxc incus, published on 22 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
Incus is a system container and virtual machine manager. In versions 6.20.0 and below, a user with the ability to launch a container with a custom YAML configuration (e.g a member of the ‘incus’ group) can create an environment variable containing newlines, which can be used to add additional configuration items in the container’s lxc.conf due to newline injection. This can allow adding arbitrary lifecycle hooks, ultimately resulting in arbitrary command execution on the host. Exploiting this issue on IncusOS requires a slight modification of the payload to change to a different writable directory for the validation step (e.g /tmp). This can be confirmed with a second container with /tmp mounted from the host (A privileged action for validation only). A fix is planned for versions 6.0.6 and 6.21.0, but they have not been released at the time of publication.
Weakness: CWE-93
Which versions are affected by CVE-2026-23953?
4 open source packages ship an affected version, including github.com/lxc/incus/v6 and github.com/lxc/incus. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/lxc/incus/v6 Go | All versions | 6.21.0 |
github.com/lxc/incus/v6 Go | All versions | 6.21.0 |
github.com/lxc/incus/v6 Go | From 6.1.0 | None |
github.com/lxc/incus Go | All versions | None |
Products include Linuxcontainers Incus.
How do I fix CVE-2026-23953?
Upgrade github.com/lxc/incus/v6 to 6.21.0 or later.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-23953 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23953 exists.
Other vulnerabilities in lxc incus
- CVE-2026-33897 Incus vulnerable to arbitrary file read and write through pongo templates
- CVE-2026-33945 Abitrary file write through systemd-creds option
- CVE-2026-33898 Local Incus UI web server vulnerable to nuthentication bypass
- CVE-2026-23954 Incus container image templating arbitrary host file read and write
- CVE-2025-64507 Incus vulnerable to local privilege escalation through custom storage volumes
Sources
Also known as DEBIAN-CVE-2026-23953, GHSA-x6jc-phwx-hp32, GO-2026-4359, UBUNTU-CVE-2026-23953.