# CVE-2026-23953: Incus container environment configuration newline injection

> A user with container launch privileges can inject newlines into environment variables to execute arbitrary commands on the host via lifecycle hooks.

- **Severity:** High 8.7 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2026
- **Updated:** 26 Jan 2026
- **Also known as:** DEBIAN-CVE-2026-23953, GHSA-x6jc-phwx-hp32, GO-2026-4359, UBUNTU-CVE-2026-23953

## What is CVE-2026-23953?

CVE-2026-23953 is a high-severity code injection vulnerability in lxc incus, published on 22 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Incus is a system container and virtual machine manager. In versions 6.20.0 and below, a user with the ability to launch a container with a custom YAML configuration (e.g a member of the ‘incus’ group) can create an environment variable containing newlines, which can be used to add additional configuration items in the container’s lxc.conf due to newline injection. This can allow adding arbitrary lifecycle hooks, ultimately resulting in arbitrary command execution on the host. Exploiting this issue on IncusOS requires a slight modification of the payload to change to a different writable directory for the validation step (e.g /tmp). This can be confirmed with a second container with /tmp mounted from the host (A privileged action for validation only). A fix is planned for versions 6.0.6
and 6.21.0, but they have not been released at the time of publication.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2026-23953?

4 open source packages ship an affected version, including github.com/lxc/incus/v6 and github.com/lxc/incus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lxc/incus/v6` | Go | All versions | 6.21.0 |
| `github.com/lxc/incus/v6` | Go | All versions | 6.21.0 |
| `github.com/lxc/incus/v6` | Go | From 6.1.0 | None |
| `github.com/lxc/incus` | Go | All versions | None |

Products: Linuxcontainers Incus.

## How do I fix CVE-2026-23953?

Upgrade github.com/lxc/incus/v6 to 6.21.0 or later.

## Is CVE-2026-23953 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23953 exists.

## Other vulnerabilities in lxc incus

- [CVE-2026-33897](https://insights.sbomify.com/CVE-2026-33897/): Incus vulnerable to arbitrary file read and write through pongo templates (critical 10.0)
- [CVE-2026-33945](https://insights.sbomify.com/CVE-2026-33945/): Abitrary file write through systemd-creds option (critical 10.0)
- [CVE-2026-33898](https://insights.sbomify.com/CVE-2026-33898/): Local Incus UI web server vulnerable to nuthentication bypass (high 8.8)
- [CVE-2026-23954](https://insights.sbomify.com/CVE-2026-23954/): Incus container image templating arbitrary host file read and write (high 8.7)
- [CVE-2025-64507](https://insights.sbomify.com/CVE-2025-64507/): Incus vulnerable to local privilege escalation through custom storage volumes (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23953 and fix it if it is affected.

What it is: CVE-2026-23953 is a high-severity code injection vulnerability in lxc incus, published on 22 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23953 exists.

Affected packages and fixed versions:
- github.com/lxc/incus/v6 (Go): affected all versions; fixed in 6.21.0
- github.com/lxc/incus/v6 (Go): affected all versions; fixed in 6.21.0
- github.com/lxc/incus/v6 (Go): affected from 6.1.0; no fix listed
- github.com/lxc/incus (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23953/ (Markdown: https://insights.sbomify.com/CVE-2026-23953/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23953
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23953
- OSV: https://osv.dev/vulnerability/CVE-2026-23953

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23953/
Summaries are generated and may contain mistakes; the official description above is the record.
