# CVE-2026-23956: seroval affected by Denial of Service via RegExp serialization

> Attackers can cause denial of service in applications using seroval by providing malicious RegExp patterns that exhaust memory or trigger catastrophic backtracking.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2026
- **Updated:** 20 May 2026
- **Also known as:** GHSA-hx9m-jf43-8ffr

## What is CVE-2026-23956?

CVE-2026-23956 is a high-severity denial of service vulnerability in lxsmnsyc seroval, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

seroval facilitates JS value stringification, including complex structures beyond JSON.stringify capabilities. In versions 0.2.0 through 1.4.0, overriding RegExp serialization with extremely large patterns can exhaust JavaScript runtime memory during deserialization. Additionally, overriding RegExp serialization with patterns that trigger catastrophic backtracking can lead to ReDoS (Regular Expression Denial of Service). This issue has been fixed in version 1.4.1.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-23956?

2 open source packages ship an affected version, including seroval. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `seroval` | npm | From 0.2.0 | 1.4.1 |
| `seroval` | npm | From 0.2.0 | 1.4.1 |

Products: Lxsmnsyc Seroval.

## How do I fix CVE-2026-23956?

Upgrade seroval to 1.4.1 or later.

## Is CVE-2026-23956 being exploited?

There is no known exploitation of CVE-2026-23956 in the wild and no public exploit code.

## Other vulnerabilities in lxsmnsyc seroval

- [CVE-2026-23957](https://insights.sbomify.com/CVE-2026-23957/): seroval is vulnerable to Denial of Service via array serialization (high 7.5)
- [CVE-2026-24006](https://insights.sbomify.com/CVE-2026-24006/): Seroval affected by Denial of Service via Deeply Nested Objects (high 7.5)
- [CVE-2026-23737](https://insights.sbomify.com/CVE-2026-23737/): seroval Affected by Remote Code Execution via JSON Deserialization (high 7.5)
- [CVE-2026-23736](https://insights.sbomify.com/CVE-2026-23736/): seroval Affected by Prototype Pollution via JSON Deserialization (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23956 and fix it if it is affected.

What it is: CVE-2026-23956 is a high-severity denial of service vulnerability in lxsmnsyc seroval, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-23956 in the wild and no public exploit code.

Affected packages and fixed versions:
- seroval (npm): affected from 0.2.0; fixed in 1.4.1
- seroval (npm): affected from 0.2.0; fixed in 1.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23956/ (Markdown: https://insights.sbomify.com/CVE-2026-23956/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23956
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23956
- OSV: https://osv.dev/vulnerability/CVE-2026-23956

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23956/
Summaries are generated and may contain mistakes; the official description above is the record.
