CVE-2026-23957 seroval is vulnerable to Denial of Service via array serialization

High 7.5 Published Updated

Attackers can cause denial of service in seroval by manipulating array lengths during deserialization, leading to excessive processing time.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-23957?

CVE-2026-23957 is a high-severity denial of service vulnerability in lxsmnsyc seroval, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

seroval facilitates JS value stringification, including complex structures beyond JSON.stringify capabilities. In versions 1.4.0 and below, overriding encoded array lengths by replacing them with an excessively large value causes the deserialization process to significantly increase processing time. This issue has been fixed in version 1.4.1.

Weakness: CWE-770

Which versions are affected by CVE-2026-23957?

2 open source packages ship an affected version, including seroval. It affects 1 product.

PackageAffectedFixed in
seroval npmAll versions1.4.1
seroval npmAll versions1.4.1

Products include Lxsmnsyc Seroval.

How do I fix CVE-2026-23957?

Upgrade seroval to 1.4.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-23957 being exploited?

There is no known exploitation of CVE-2026-23957 in the wild and no public exploit code.

Sources

Also known as GHSA-66fc-rw6m-c2q6.

Is CVE-2026-23957 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free