# CVE-2026-23959: CoreShop Vulnerable to SQL Injection via Admin customer-company-modifier


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Jan 2026
- **Updated:** 22 Jan 2026
- **Also known as:** GHSA-fqcv-8859-86x2

## What is CVE-2026-23959?

CVE-2026-23959 is a medium-severity vulnerability in CoreShop, published on 22 Jan 2026. 

### Official description

CoreShop is a Pimcore enhanced eCommerce solution. An error-based SQL Injection vulnerability was identified in versions prior to 4.1.9 in the `CustomerTransformerController` within the CoreShop admin panel. The affected endpoint improperly interpolates user-supplied input into a SQL query, leading to database error disclosure and potential data extraction. Version 4.1.9 fixes the issue.

Weakness: CWE-564 (Use of Hibernate with HQL/SQL Query String Containing External Input)

## Which versions are affected by CVE-2026-23959?

2 open source packages ship an affected version, including coreshop/core-shop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `coreshop/core-shop` | Packagist | All versions | 4.1.9 |
| `coreshop/core-shop` | Packagist | All versions | 4.1.9 |

Products: Coreshop Coreshop.

## How do I fix CVE-2026-23959?

Upgrade coreshop/core-shop to 4.1.9 or later.

## Is CVE-2026-23959 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23959 exists.

## Other vulnerabilities in CoreShop

- [CVE-2026-22242](https://insights.sbomify.com/CVE-2026-22242/): CoreShop Vulnerable to SQL Injection via Admin Reports (medium 4.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23959 and fix it if it is affected.

What it is: CVE-2026-23959 is a medium-severity vulnerability in CoreShop, published on 22 Jan 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-23959 exists.

Affected packages and fixed versions:
- coreshop/core-shop (Packagist): affected all versions; fixed in 4.1.9
- coreshop/core-shop (Packagist): affected all versions; fixed in 4.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23959/ (Markdown: https://insights.sbomify.com/CVE-2026-23959/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23959
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23959
- OSV: https://osv.dev/vulnerability/CVE-2026-23959

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23959/
Summaries are generated and may contain mistakes; the official description above is the record.
