{"answers":{"affected":"1 open source package ship an affected version, including mastodon. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-23962 in the wild and no public exploit code.","fix":"Upgrade mastodon to a fixed version for your release line: 4.3.18, 4.4.12 or 4.5.5.","what":"CVE-2026-23962 is a high-severity denial of service vulnerability in mastodon, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-23962 and fix it if it is affected.\n\nWhat it is: CVE-2026-23962 is a high-severity denial of service vulnerability in mastodon, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-23962 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mastodon (Bitnami): affected all versions; fixed in 4.3.18, 4.4.12, 4.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-23962/ (Markdown: https://insights.sbomify.com/CVE-2026-23962/index.md)","id":"CVE-2026-23962","markdown":"https://insights.sbomify.com/CVE-2026-23962/index.md","name":"CVE-2026-23962","record":{"aliases":["BIT-mastodon-2026-23962","GHSA-gg8q-rcg7-p79g"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Mastodon social network","requires_auth":"none","summary":"Attackers can cause Denial of Service on Mastodon servers and clients by creating posts with excessive poll options, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"mastodon","vendor":"joinmastodon"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Mastodon is a free, open-source social network server based on ActivityPub. Mastodon versions before v4.3.18, v4.4.12, and v4.5.5 do not have a limit on the maximum number of poll options for remote posts, allowing attackers to create polls with a very large amount of options, greatly increasing resource consumption. Depending on the number of poll options, an attacker can cause disproportionate resource usage in both Mastodon servers and clients, potentially causing Denial of Service either server-side or client-side. Mastodon versions v4.5.5, v4.4.12, v4.3.18 are patched.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mastodon vulnerable to Denial of Service from a single post (client/server)","id":"CVE-2026-23962","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":4,"next":{"headline":"Mastodon missing length limits on list names, filter names, and filter keywords","id":"CVE-2026-23963"},"packages":[{"ecosystem":"Bitnami","fixed":["4.3.18","4.4.12","4.5.5"],"introduced":["0","4.4.0","4.5.0"],"last_affected":[],"package":"mastodon","purl":"pkg:bitnami/mastodon","source":"BIT-mastodon-2026-23962"}],"prev":{"headline":"Mastodon may allow a remote suspension bypass","id":"CVE-2026-23961"},"products":["mastodon"],"published":"2026-01-22","related":[{"cvss_score":10,"headline":"Mastodon vulnerable to arbitrary file creation through media attachments","id":"CVE-2023-36460","kev_date_added":null,"published":"2023-07-06"},{"cvss_score":9.8,"headline":"Improper Restriction of Excessive Authentication Attempts in mastodon/mastodon","id":"CVE-2022-2166","kev_date_added":null,"published":"2022-11-16"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2022-24307","kev_date_added":null,"published":"2022-02-03"},{"cvss_score":9.8,"headline":"Auth bypass in n/a","id":"CVE-2018-21018","kev_date_added":null,"published":"2019-09-22"},{"cvss_score":9.4,"headline":"Mastodon Remote user impersonation and takeover","id":"CVE-2024-23832","kev_date_added":null,"published":"2024-02-01"},{"cvss_score":9.3,"headline":"Mastodon vulnerable to Cross-site Scripting through oEmbed preview cards","id":"CVE-2023-36459","kev_date_added":null,"published":"2023-07-06"},{"cvss_score":8.5,"headline":"Lack of media type verification of Activity Streams objects allows impersonation of remote accounts","id":"CVE-2024-25623","kev_date_added":null,"published":"2024-02-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-22","vendors":["mastodon"]},"summary":"Attackers can cause Denial of Service on Mastodon servers and clients by creating posts with excessive poll options, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2026-23962/"}