# CVE-2026-23982: Apache Superset: Improper Authorization in Dataset Creation Allows Access Control Bypass

> An authenticated attacker can bypass data access controls by overwriting SQL queries in existing datasets, allowing unauthorized data access.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2026
- **Updated:** 24 Feb 2026
- **Also known as:** BIT-superset-2026-23982, ECHO-2feb-a625-78ca, GHSA-3m2g-v7jf-7fxc, PYSEC-2026-2372

## What is CVE-2026-23982?

CVE-2026-23982 is a high-severity missing authorization vulnerability in Apache Superset, published on 24 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An Improper Authorization vulnerability exists in Apache Superset that allows a low-privileged user to bypass data access controls. When creating a dataset, Superset enforces permission checks to prevent users from querying unauthorized data. However, an authenticated attacker with permissions to write datasets and read charts can bypass these checks by overwriting the SQL query of an existing dataset.

This issue affects Apache Superset: before 6.0.0.

Users are recommended to upgrade to version 6.0.0, which fixes the issue.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-23982?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 6.0.0 |
| `apache-superset` | PyPI | All versions | 6.0.0 |
| `apache-superset` | PyPI | All versions | 6.0.0 |
| `superset` | Bitnami | All versions | 6.0.0 |

Products: Apache Superset.

## How do I fix CVE-2026-23982?

Upgrade apache-superset to 6.0.0 or later.

## Is CVE-2026-23982 being exploited?

There is no known exploitation of CVE-2026-23982 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23982 and fix it if it is affected.

What it is: CVE-2026-23982 is a high-severity missing authorization vulnerability in Apache Superset, published on 24 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-23982 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 6.0.0
- apache-superset (PyPI): affected all versions; fixed in 6.0.0
- apache-superset (PyPI): affected all versions; fixed in 6.0.0
- superset (Bitnami): affected all versions; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23982/ (Markdown: https://insights.sbomify.com/CVE-2026-23982/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23982
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23982
- OSV: https://osv.dev/vulnerability/CVE-2026-23982

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23982/
Summaries are generated and may contain mistakes; the official description above is the record.
