{"answers":{"affected":"4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-23983 in the wild and no public exploit code.","fix":"Upgrade apache-superset to 6.0.0 or later.","what":"CVE-2026-23983 is a low-severity vulnerability in Apache Superset, published on 24 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-23983 and fix it if it is affected.\n\nWhat it is: CVE-2026-23983 is a low-severity vulnerability in Apache Superset, published on 24 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-23983 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-superset (PyPI): affected all versions; fixed in 6.0.0\n- apache-superset (PyPI): affected all versions; fixed in 6.0.0\n- apache-superset (PyPI): affected all versions; fixed in 6.0.0\n- superset (Bitnami): affected all versions; fixed in 6.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-23983/ (Markdown: https://insights.sbomify.com/CVE-2026-23983/index.md)","id":"CVE-2026-23983","markdown":"https://insights.sbomify.com/CVE-2026-23983/index.md","name":"CVE-2026-23983","record":{"aliases":["BIT-superset-2026-23983","ECHO-91e6-90e7-361a","GHSA-h294-8fxm-m2pj","PYSEC-2026-2375"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Superset","requires_auth":"low_privilege","summary":"Authenticated users can expose sensitive user data like password hashes via the Tag API if the tagging system is enabled.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"superset","vendor":"apache"}],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A Sensitive Data Exposure vulnerability exists in Apache Superset allowing authenticated users to retrieve sensitive user information. The Tag endpoint (disabled by default) allows users to retrieve a list of objects associated with a specific tag.\nWhen these associated objects include Users, the API response improperly serializes and returns sensitive fields, including password hashes (pbkdf2), email addresses, and login statistics. This vulnerability allows authenticated users with low privileges (e.g., Gamma role) to view sensitive authentication data \n\nThis issue affects Apache Superset: before 6.0.0.\n\nUsers are recommended to upgrade to version 6.0.0, which fixes the issue or make sure TAGGING_SYSTEM is False (Apache Superset current default)","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Superset: Sensitive Data Exposure via REST API (disabled by default)","id":"CVE-2026-23983","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:superset","products":["apache:superset"],"type":"information_disclosure","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"Apache Superset: SQLLab Read-Only Bypass on PostgreSQL","id":"CVE-2026-23984"},"packages":[{"ecosystem":"Bitnami","fixed":["6.0.0"],"introduced":["0"],"last_affected":[],"package":"superset","purl":"pkg:bitnami/superset","source":"BIT-superset-2026-23983"},{"ecosystem":"PyPI","fixed":["6.0.0"],"introduced":["0"],"last_affected":[],"package":"apache-superset","purl":null,"source":"GHSA-h294-8fxm-m2pj"},{"ecosystem":"PyPI","fixed":["6.0.0"],"introduced":["0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"GHSA-h294-8fxm-m2pj"},{"ecosystem":"PyPI","fixed":["6.0.0"],"introduced":["0"],"last_affected":[],"package":"apache-superset","purl":"pkg:pypi/apache-superset","source":"PYSEC-2026-2375"}],"prev":{"headline":"Apache Superset: Improper Authorization in Dataset Creation Allows Access Control Bypass","id":"CVE-2026-23982"},"products":["Apache Superset"],"published":"2026-02-24","related":[{"cvss_score":8.9,"headline":"Apache Superset Insecure Default Initialization of Resource","id":"CVE-2023-27524","kev_date_added":"2024-01-08","published":"2023-04-24"},{"cvss_score":9.8,"headline":"SQL injection vulnerability in chart data API","id":"CVE-2022-27479","kev_date_added":null,"published":"2022-04-13"},{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in superset","id":"CVE-2018-8021","kev_date_added":null,"published":"2018-11-07"},{"cvss_score":9.6,"headline":"Apache Superset: Stored XSS in Dashboard Title and Chart Title","id":"CVE-2023-49657","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":8.8,"headline":"Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API","id":"CVE-2022-43719","kev_date_added":null,"published":"2023-01-16"},{"cvss_score":8.8,"headline":"Possible SQL Injection when template processing is enabled","id":"CVE-2021-41971","kev_date_added":null,"published":"2021-10-18"},{"cvss_score":8.8,"headline":"Apache Superset OS Command Injection","id":"CVE-2020-13948","kev_date_added":null,"published":"2020-09-17"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-24","vendors":["Apache Software Foundation"]},"summary":"Authenticated users can expose sensitive user data like password hashes via the Tag API if the tagging system is enabled.","url":"https://insights.sbomify.com/CVE-2026-23983/"}