# CVE-2026-23983: Apache Superset: Sensitive Data Exposure via REST API (disabled by default)

> Authenticated users can expose sensitive user data like password hashes via the Tag API if the tagging system is enabled.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2026
- **Updated:** 24 Feb 2026
- **Also known as:** BIT-superset-2026-23983, ECHO-91e6-90e7-361a, GHSA-h294-8fxm-m2pj, PYSEC-2026-2375

## What is CVE-2026-23983?

CVE-2026-23983 is a low-severity vulnerability in Apache Superset, published on 24 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A Sensitive Data Exposure vulnerability exists in Apache Superset allowing authenticated users to retrieve sensitive user information. The Tag endpoint (disabled by default) allows users to retrieve a list of objects associated with a specific tag.
When these associated objects include Users, the API response improperly serializes and returns sensitive fields, including password hashes (pbkdf2), email addresses, and login statistics. This vulnerability allows authenticated users with low privileges (e.g., Gamma role) to view sensitive authentication data 

This issue affects Apache Superset: before 6.0.0.

Users are recommended to upgrade to version 6.0.0, which fixes the issue or make sure TAGGING_SYSTEM is False (Apache Superset current default)

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-23983?

4 open source packages ship an affected version, including apache-superset and superset. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-superset` | PyPI | All versions | 6.0.0 |
| `apache-superset` | PyPI | All versions | 6.0.0 |
| `apache-superset` | PyPI | All versions | 6.0.0 |
| `superset` | Bitnami | All versions | 6.0.0 |

Products: Apache Superset.

## How do I fix CVE-2026-23983?

Upgrade apache-superset to 6.0.0 or later.

## Is CVE-2026-23983 being exploited?

There is no known exploitation of CVE-2026-23983 in the wild and no public exploit code.

## Other vulnerabilities in Apache Superset

- [CVE-2023-27524](https://insights.sbomify.com/CVE-2023-27524/): Apache Superset Insecure Default Initialization of Resource (high 8.9, exploited in the wild)
- [CVE-2022-27479](https://insights.sbomify.com/CVE-2022-27479/): SQL injection vulnerability in chart data API (critical 9.8)
- [CVE-2018-8021](https://insights.sbomify.com/CVE-2018-8021/): Deserialization of Untrusted Data in superset (critical 9.8)
- [CVE-2023-49657](https://insights.sbomify.com/CVE-2023-49657/): Apache Superset: Stored XSS in Dashboard Title and Chart Title (critical 9.6)
- [CVE-2022-43719](https://insights.sbomify.com/CVE-2022-43719/): Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23983 and fix it if it is affected.

What it is: CVE-2026-23983 is a low-severity vulnerability in Apache Superset, published on 24 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-23983 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-superset (PyPI): affected all versions; fixed in 6.0.0
- apache-superset (PyPI): affected all versions; fixed in 6.0.0
- apache-superset (PyPI): affected all versions; fixed in 6.0.0
- superset (Bitnami): affected all versions; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23983/ (Markdown: https://insights.sbomify.com/CVE-2026-23983/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23983
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23983
- OSV: https://osv.dev/vulnerability/CVE-2026-23983

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23983/
Summaries are generated and may contain mistakes; the official description above is the record.
