CVE-2026-23985 Apache Superset: Regular Expression Denial of Service (ReDoS) in SQL Parser
An authenticated attacker can cause a denial of service in Apache Superset by sending maliciously crafted SQL queries that trigger a regular expression vulnerability.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-23985?
CVE-2026-23985 is a medium-severity denial of service vulnerability in Apache Superset, published on 30 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A Regular Expression Denial of Service (ReDoS) vulnerability exists in Apache Superset versions 1.5.0 through 5.0.0. The vulnerability is located in the sql_parse.py component, specifically within the SQL_REGEX used for parsing SQL statements in the sqlparse library integration. The affected regular expression contains overlapping disjunctions that share a common outer quantifier. An authenticated attacker can exploit this by sending a maliciously crafted input string (specifically a long sequence of backslashes or similar characters) to endpoints that process SQL queries
This issue affects Apache Superset: before 6.0.0.
Users are recommended to upgrade to version 6.0.0, which fixes the issue.
Workarounds: ● WAF Rules: Implement Web Application Firewall (WAF) rules to detect and block requests containing excessively long sequences of backslashes or suspicious repeated patterns in the queries.extras.where parameter. ● Rate Limiting: Ensure strict rate limiting is applied to the /api/v1/chart/data endpoint to reduce the impact of potential attacks.
Weakness: CWE-1333
Which versions are affected by CVE-2026-23985?
1 open source package ship an affected version, including superset. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
superset Bitnami | All versions | 6.0.0 |
Products include Apache Superset.
How do I fix CVE-2026-23985?
Upgrade superset to 6.0.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-23985 being exploited?
There is no known exploitation of CVE-2026-23985 in the wild and no public exploit code.
Other vulnerabilities in Apache Superset
- CVE-2023-27524 Apache Superset Insecure Default Initialization of Resource
- CVE-2022-27479 SQL injection vulnerability in chart data API
- CVE-2018-8021 Deserialization of Untrusted Data in superset
- CVE-2023-49657 Apache Superset: Stored XSS in Dashboard Title and Chart Title
- CVE-2022-43719 Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API
Sources
Also known as BIT-superset-2026-23985, GHSA-92hr-7q6h-w7c4.