{"answers":{"affected":"1 open source package ship an affected version, including superset. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-23985 in the wild and no public exploit code.","fix":"Upgrade superset to 6.0.0 or later.","what":"CVE-2026-23985 is a medium-severity denial of service vulnerability in Apache Superset, published on 30 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-23985 and fix it if it is affected.\n\nWhat it is: CVE-2026-23985 is a medium-severity denial of service vulnerability in Apache Superset, published on 30 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-23985 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- superset (Bitnami): affected all versions; fixed in 6.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-23985/ (Markdown: https://insights.sbomify.com/CVE-2026-23985/index.md)","id":"CVE-2026-23985","markdown":"https://insights.sbomify.com/CVE-2026-23985/index.md","name":"CVE-2026-23985","record":{"aliases":["BIT-superset-2026-23985","GHSA-92hr-7q6h-w7c4"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Superset","requires_auth":"low_privilege","summary":"An authenticated attacker can cause a denial of service in Apache Superset by sending maliciously crafted SQL queries that trigger a regular expression vulnerability.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"superset","vendor":"apache"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"A Regular Expression Denial of Service (ReDoS) vulnerability exists in Apache Superset versions 1.5.0 through 5.0.0. The vulnerability is located in the sql_parse.py component, specifically within the SQL_REGEX used for parsing SQL statements in the sqlparse library integration.\nThe affected regular expression contains overlapping disjunctions that share a common outer quantifier. An authenticated attacker can exploit this by sending a maliciously crafted input string (specifically a long sequence of backslashes or similar characters) to endpoints that process SQL queries\n\nThis issue affects Apache Superset: before 6.0.0.\n\nUsers are recommended to upgrade to version 6.0.0, which fixes the issue. \n\nWorkarounds:\n● WAF Rules: Implement Web Application Firewall (WAF) rules to detect and block\nrequests containing excessively long sequences of backslashes or suspicious repeated\npatterns in the queries.extras.where parameter.\n● Rate Limiting: Ensure strict rate limiting is applied to the /api/v1/chart/data endpoint to\nreduce the impact of potential attacks.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Superset: Regular Expression Denial of Service (ReDoS) in SQL Parser","id":"CVE-2026-23985","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:superset","products":["apache:superset"],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Copier safe template has arbitrary filesystem write access via directory symlinks when _preserve_symlinks: true","id":"CVE-2026-23986"},"packages":[{"ecosystem":"Bitnami","fixed":["6.0.0"],"introduced":["0"],"last_affected":[],"package":"superset","purl":"pkg:bitnami/superset","source":"BIT-superset-2026-23985"}],"prev":{"headline":"Apache Superset: SQLLab Read-Only Bypass on PostgreSQL","id":"CVE-2026-23984"},"products":["Apache Superset"],"published":"2026-07-30","related":[{"cvss_score":8.9,"headline":"Apache Superset Insecure Default Initialization of Resource","id":"CVE-2023-27524","kev_date_added":"2024-01-08","published":"2023-04-24"},{"cvss_score":9.8,"headline":"SQL injection vulnerability in chart data API","id":"CVE-2022-27479","kev_date_added":null,"published":"2022-04-13"},{"cvss_score":9.8,"headline":"Deserialization of Untrusted Data in superset","id":"CVE-2018-8021","kev_date_added":null,"published":"2018-11-07"},{"cvss_score":9.6,"headline":"Apache Superset: Stored XSS in Dashboard Title and Chart Title","id":"CVE-2023-49657","kev_date_added":null,"published":"2024-01-23"},{"cvss_score":8.8,"headline":"Apache Superset: Cross Site Request Forgery (CSRF) on accept, request access API","id":"CVE-2022-43719","kev_date_added":null,"published":"2023-01-16"},{"cvss_score":8.8,"headline":"Possible SQL Injection when template processing is enabled","id":"CVE-2021-41971","kev_date_added":null,"published":"2021-10-18"},{"cvss_score":8.8,"headline":"Apache Superset OS Command Injection","id":"CVE-2020-13948","kev_date_added":null,"published":"2020-09-17"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-30","vendors":["Apache Software Foundation"]},"summary":"An authenticated attacker can cause a denial of service in Apache Superset by sending maliciously crafted SQL queries that trigger a regular expression vulnerability.","url":"https://insights.sbomify.com/CVE-2026-23985/"}