# CVE-2026-23990: Flux Operator Web UI Impersonation Bypass via Empty OIDC Claims

> Attackers can bypass RBAC impersonation in Flux Operator Web UI to execute API requests with operator privileges, leading to privilege escalation and data exposure.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jan 2026
- **Updated:** 22 Jan 2026
- **Also known as:** GHSA-4xh5-jcj2-ch8q, GO-2026-4351

## What is CVE-2026-23990?

CVE-2026-23990 is a medium-severity vulnerability in controlplaneio-fluxcd flux-operator, published on 21 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Flux Operator is a Kubernetes CRD controller that manages the lifecycle of CNCF Flux CD and the ControlPlane enterprise distribution. Starting in version 0.36.0 and prior to version 0.40.0, a privilege escalation vulnerability exists in the Flux Operator Web UI authentication code that allows an attacker to bypass Kubernetes RBAC impersonation and execute API requests with the operator's service account privileges. In order to be vulnerable, cluster admins must configure the Flux Operator with an OIDC provider that issues tokens lacking the expected claims (e.g., `email`, `groups`), or configure custom CEL expressions that can evaluate to empty values. After OIDC token claims are processed through CEL expressions, there is no validation that the resulting `username` and `groups` values are non-empty. When both values are empty, the Kubernetes client-go library does not add impersonation headers to API requests, causing them to be executed with the flux-operator service account's credentials instead of the authenticated user's limited permissions. This can result in privilege escalation, data exposure, and/or information disclosure. Version 0.40.0 patches the issue.

Weakness: CWE-862 (Missing Authorization), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-23990?

3 open source packages ship an affected version, including github.com/controlplaneio-fluxcd/flux-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/controlplaneio-fluxcd/flux-operator` | Go | From 0.36.0 | 0.40.0 |
| `github.com/controlplaneio-fluxcd/flux-operator` | Go | From 0.36.0 | 0.40.0 |
| `github.com/controlplaneio-fluxcd/flux-operator` | Go | From 0.36.0 | 0.40.0 |

Products: Control-Plane Flux Operator.

## How do I fix CVE-2026-23990?

Upgrade github.com/controlplaneio-fluxcd/flux-operator to 0.40.0 or later.

## Is CVE-2026-23990 being exploited?

There is no known exploitation of CVE-2026-23990 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23990 and fix it if it is affected.

What it is: CVE-2026-23990 is a medium-severity vulnerability in controlplaneio-fluxcd flux-operator, published on 21 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-23990 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/controlplaneio-fluxcd/flux-operator (Go): affected from 0.36.0; fixed in 0.40.0
- github.com/controlplaneio-fluxcd/flux-operator (Go): affected from 0.36.0; fixed in 0.40.0
- github.com/controlplaneio-fluxcd/flux-operator (Go): affected from 0.36.0; fixed in 0.40.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23990/ (Markdown: https://insights.sbomify.com/CVE-2026-23990/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23990
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23990
- OSV: https://osv.dev/vulnerability/CVE-2026-23990

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23990/
Summaries are generated and may contain mistakes; the official description above is the record.
