# CVE-2026-23999: Fleet: Device lock PIN can be predicted if lock time is known

> Attackers with physical access and timing knowledge can predict device lock PINs due to weak entropy, bypassing lock controls.

- **Severity:** Low 0.6 (`CVSS:4.0/AV:P/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-ppwx-5jq7-px2w, GO-2026-4564

## What is CVE-2026-23999?

CVE-2026-23999 is a low-severity vulnerability in fleetdm fleet, published on 26 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Fleet is open source device management software. In versions prior to 4.80.1, Fleet generated device lock and wipe PINs using a predictable algorithm based solely on the current Unix timestamp. Because no secret key or additional entropy was used, the resulting PIN could potentially be derived if the approximate time the device was locked is known. Fleet’s device lock and wipe commands generate a 6-digit PIN that is displayed to administrators for unlocking a device. In affected versions, this PIN was deterministically derived from the current timestamp. An attacker with physical possession of a locked device and knowledge of the approximate time the lock command was issued could theoretically predict the correct PIN within a limited search window. However, successful exploitation is constrained by multiple factors: Physical access to the device is required, the approximate lock time must be known, the operating system enforces rate limiting on PIN entry attempts, attempts would need to be spread over, and device wipe operations would typically complete before sufficient attempts could be made. As a result, this issue does not allow remote exploitation, fleet-wide compromise, or bypass of Fleet authentication controls. Version 4.80.1 contains a patch. No known workarounds are available.

Weakness: CWE-330 (Use of Insufficiently Random Values)

## Which versions are affected by CVE-2026-23999?

3 open source packages ship an affected version, including github.com/fleetdm/fleet/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.80.1 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.80.1 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.80.1 |

Products: Fleetdm Fleet.

## How do I fix CVE-2026-23999?

Upgrade github.com/fleetdm/fleet/v4 to 4.80.1 or later.

## Is CVE-2026-23999 being exploited?

There is no known exploitation of CVE-2026-23999 in the wild and no public exploit code.

## Other vulnerabilities in fleetdm fleet

- [CVE-2020-26276](https://insights.sbomify.com/CVE-2020-26276/): SAML authentication vulnerability in Fleet (critical 10.0)
- [CVE-2026-103264](https://insights.sbomify.com/CVE-2026-103264/): Fleet before 4.87.0 Authentication Bypass via Device Identifiers (critical 9.3)
- [CVE-2026-23518](https://insights.sbomify.com/CVE-2026-23518/): Fleet has a JWT signature bypass vulnerability in Azure AD MDM enrollment (critical 9.3)
- [CVE-2026-26062](https://insights.sbomify.com/CVE-2026-26062/): Fleet server may terminate unexpectedly when handling certain gRPC requests (high 8.7)
- [CVE-2026-26061](https://insights.sbomify.com/CVE-2026-26061/): Fleet's unbounded request body read allows remote Denial of Service (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-23999 and fix it if it is affected.

What it is: CVE-2026-23999 is a low-severity vulnerability in fleetdm fleet, published on 26 Feb 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-23999 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.80.1
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.80.1
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.80.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-23999/ (Markdown: https://insights.sbomify.com/CVE-2026-23999/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-23999
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-23999
- OSV: https://osv.dev/vulnerability/CVE-2026-23999

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-23999/
Summaries are generated and may contain mistakes; the official description above is the record.
