# CVE-2026-24000: Fleet has a rate limiting bypass via untrusted client IP headers

> Attackers can bypass IP-based rate limits in Fleet by spoofing client IP headers, facilitating brute-force attacks against authentication endpoints.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2026
- **Updated:** 14 May 2026
- **Also known as:** GHSA-j8h8-75h3-jg53, GO-2026-5455

## What is CVE-2026-24000?

CVE-2026-24000 is a medium-severity vulnerability in fleetdm fleet, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fleet is open source device management software. Prior to version 4.80.1, Fleet trusted client-supplied IP address headers when determining the source IP for incoming requests. This allowed authenticated and unauthenticated clients to spoof their apparent IP address and bypass per-IP rate limiting controls. Fleet determines a client’s public IP address using HTTP headers such as X-Forwarded-For, X-Real-IP, and/or True-Client-IP. These headers were trusted without validation. An attacker could supply arbitrary values in these headers, causing Fleet to treat each request as originating from a different IP address. This could allow an attacker to bypass per-IP rate limits and increase the effectiveness of brute-force or password-spraying attempts against authentication endpoints. This issue does not allow authentication bypass, privilege escalation, data exposure, or remote code execution on its own. Version 4.80.1 contains a patch. As a workaround, run Fleet behind a trusted reverse proxy or load balancer that overwrites client IP headers.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-24000?

3 open source packages ship an affected version, including github.com/fleetdm/fleet/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.80.1 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.80.1 |
| `github.com/fleetdm/fleet/v4` | Go | All versions | 4.80.1 |

Products: Fleetdm Fleet.

## How do I fix CVE-2026-24000?

Upgrade github.com/fleetdm/fleet/v4 to 4.80.1 or later.

## Is CVE-2026-24000 being exploited?

There is no known exploitation of CVE-2026-24000 in the wild and no public exploit code.

## Other vulnerabilities in fleetdm fleet

- [CVE-2020-26276](https://insights.sbomify.com/CVE-2020-26276/): SAML authentication vulnerability in Fleet (critical 10.0)
- [CVE-2026-103264](https://insights.sbomify.com/CVE-2026-103264/): Fleet before 4.87.0 Authentication Bypass via Device Identifiers (critical 9.3)
- [CVE-2026-23518](https://insights.sbomify.com/CVE-2026-23518/): Fleet has a JWT signature bypass vulnerability in Azure AD MDM enrollment (critical 9.3)
- [CVE-2026-26062](https://insights.sbomify.com/CVE-2026-26062/): Fleet server may terminate unexpectedly when handling certain gRPC requests (high 8.7)
- [CVE-2026-26061](https://insights.sbomify.com/CVE-2026-26061/): Fleet's unbounded request body read allows remote Denial of Service (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24000 and fix it if it is affected.

What it is: CVE-2026-24000 is a medium-severity vulnerability in fleetdm fleet, published on 14 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24000 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.80.1
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.80.1
- github.com/fleetdm/fleet/v4 (Go): affected all versions; fixed in 4.80.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24000/ (Markdown: https://insights.sbomify.com/CVE-2026-24000/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24000
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24000
- OSV: https://osv.dev/vulnerability/CVE-2026-24000

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24000/
Summaries are generated and may contain mistakes; the official description above is the record.
