CVE-2026-24001 jsdiff has a Denial of Service vulnerability in parsePatch and applyPatch
Attackers can cause a denial of service in applications using jsdiff by providing patches with specific line break characters, leading to infinite loops or excessive CPU usage.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-24001?
CVE-2026-24001 is a low-severity denial of service vulnerability in kpdecker jsdiff, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
jsdiff is a JavaScript text differencing implementation. Prior to versions 8.0.3, 5.2.2, 4.0.4, and 3.5.1, attempting to parse a patch whose filename headers contain the line break characters `\r`, `\u2028`, or `\u2029` can cause the `parsePatch` method to enter an infinite loop. It then consumes memory without limit until the process crashes due to running out of memory. Applications are therefore likely to be vulnerable to a denial-of-service attack if they call `parsePatch` with a user-provided patch as input. A large payload is not needed to trigger the vulnerability, so size limits on user input do not provide any protection. Furthermore, some applications may be vulnerable even when calling `parsePatch` on a patch generated by the application itself if the user is nonetheless able to control the filename headers (e.g. by directly providing the filenames of the files to be diffed). The `applyPatch` method is similarly affected if (and only if) called with a string representation of a patch as an argument, since under the hood it parses that string using `parsePatch`. Other methods of the library are unaffected. Finally, a second and lesser interdependent bug - a ReDOS - also exhibits when those same line break characters are present in a patch's *patch* header (also known as its "leading garbage"). A maliciously-crafted patch header of length *n* can take `parsePatch` O(*n*³) time to parse. Versions 8.0.3, 5.2.2, 4.0.4, and 3.5.1 contain a fix. As a workaround, do not attempt to parse patches that contain any of these characters: `\r`, `\u2028`, or `\u2029`.
Which versions are affected by CVE-2026-24001?
8 open source packages ship an affected version, including diff. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
diff npm | All versions | 3.5.1 |
diff npm | All versions | 3.5.1 |
diff npm | From 4.0.0 | 4.0.4 |
diff npm | From 4.0.0 | 4.0.4 |
diff npm | From 5.0.0 | 5.2.2 |
diff npm | From 5.0.0 | 5.2.2 |
2 more packages
diff npm | From 6.0.0 | 8.0.3 |
diff npm | From 6.0.0 | 8.0.3 |
Products include Kpdecker Jsdiff.
How do I fix CVE-2026-24001?
Upgrade diff to a fixed version for your release line: 3.5.1, 4.0.4, 5.2.2 or 8.0.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-24001 being exploited?
There is no known exploitation of CVE-2026-24001 in the wild and no public exploit code.
Sources
Also known as CLEANSTART-2026-JK65997, CLEANSTART-2026-KX54360, CLSA-2026-1773188145, CLSA-2026-1774225207, CLSA-2026-1780361390, CLSA-2026-1780361406 and 21 more.