CVE-2026-24005 OpenKruise PodProbeMarker is Vulnerable to SSRF via Unrestricted Host Field
Attackers with PodProbeMarker permissions can trigger SSRF from the node network namespace to scan ports and read responses.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-24005?
CVE-2026-24005 is a server-side request forgery vulnerability in openkruise kruise, published on 25 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Kruise provides automated management of large-scale applications on Kubernetes. Prior to versions 1.8.3 and 1.7.5, PodProbeMarker allows defining custom probes with TCPSocket or HTTPGet handlers. The webhook validation does not restrict the Host field in these probe configurations. Since kruise-daemon runs with hostNetwork=true, it executes probes from the node network namespace. An attacker with PodProbeMarker creation permission can specify arbitrary Host values to trigger SSRF from the node, perform port scanning, and receive response feedback through NodePodProbe status messages. Versions 1.8.3 and 1.7.5 patch the issue.
Weakness: CWE-918
Which versions are affected by CVE-2026-24005?
5 open source packages ship an affected version, including github.com/openkruise/kruise. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/openkruise/kruise Go | All versions | 1.7.5, 1.8.3 |
github.com/openkruise/kruise Go | All versions | 1.7.5 |
github.com/openkruise/kruise Go | All versions | 1.7.5 |
github.com/openkruise/kruise Go | From 1.8.0 | 1.8.3 |
github.com/openkruise/kruise Go | From 1.8.0 | 1.8.3 |
Products include Openkruise Kruise.
How do I fix CVE-2026-24005?
Upgrade github.com/openkruise/kruise to a fixed version for your release line: 1.7.5 or 1.8.3.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-24005 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24005 exists.
Other vulnerabilities in openkruise kruise
Sources
Also known as GHSA-9fj4-3849-rv9g, GO-2026-4549.