{"answers":{"affected":"2 open source packages ship an affected version, including seroval. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-24006 in the wild and no public exploit code.","fix":"Upgrade seroval to 1.4.1 or later.","what":"CVE-2026-24006 is a high-severity denial of service vulnerability in lxsmnsyc seroval, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-24006 and fix it if it is affected.\n\nWhat it is: CVE-2026-24006 is a high-severity denial of service vulnerability in lxsmnsyc seroval, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-24006 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- seroval (npm): affected all versions; fixed in 1.4.1\n- seroval (npm): affected all versions; fixed in 1.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-24006/ (Markdown: https://insights.sbomify.com/CVE-2026-24006/index.md)","id":"CVE-2026-24006","markdown":"https://insights.sbomify.com/CVE-2026-24006/index.md","name":"CVE-2026-24006","record":{"aliases":["GHSA-3j22-8qj3-26mx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript serialization library","requires_auth":"none","summary":"Attackers can cause a denial of service by providing deeply nested objects to the Seroval library, exceeding the call stack limit.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"seroval","vendor":"lxsmnsyc"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"Seroval facilitates JS value stringification, including complex structures beyond JSON.stringify capabilities. In versions 1.4.0\nand below, serialization of objects with extreme depth can exceed the maximum call stack limit. In version 1.4.1, Seroval introduces a `depthLimit` parameter in serialization/deserialization methods. An error will be thrown if the depth limit is reached.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Seroval affected by Denial of Service via Deeply Nested Objects","id":"CVE-2026-24006","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Tuleap is missing CSRF protection in the Overview inconsistent items","id":"CVE-2026-24007"},"packages":[{"ecosystem":"npm","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"seroval","purl":null,"source":"GHSA-3j22-8qj3-26mx"},{"ecosystem":"npm","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"seroval","purl":"pkg:npm/seroval","source":"GHSA-3j22-8qj3-26mx"}],"prev":{"headline":"OpenKruise PodProbeMarker is Vulnerable to SSRF via Unrestricted Host Field","id":"CVE-2026-24005"},"products":["seroval"],"published":"2026-01-22","related":[{"cvss_score":7.5,"headline":"seroval affected by Denial of Service via RegExp serialization","id":"CVE-2026-23956","kev_date_added":null,"published":"2026-01-22"},{"cvss_score":7.5,"headline":"seroval is vulnerable to Denial of Service via array serialization","id":"CVE-2026-23957","kev_date_added":null,"published":"2026-01-22"},{"cvss_score":7.5,"headline":"seroval Affected by Remote Code Execution via JSON Deserialization","id":"CVE-2026-23737","kev_date_added":null,"published":"2026-01-21"},{"cvss_score":7.3,"headline":"seroval Affected by Prototype Pollution via JSON Deserialization","id":"CVE-2026-23736","kev_date_added":null,"published":"2026-01-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-22","vendors":["lxsmnsyc"]},"summary":"Attackers can cause a denial of service by providing deeply nested objects to the Seroval library, exceeding the call stack limit.","url":"https://insights.sbomify.com/CVE-2026-24006/"}