# CVE-2026-24006: Seroval affected by Denial of Service via Deeply Nested Objects

> Attackers can cause a denial of service by providing deeply nested objects to the Seroval library, exceeding the call stack limit.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2026
- **Updated:** 22 Jan 2026
- **Also known as:** GHSA-3j22-8qj3-26mx

## What is CVE-2026-24006?

CVE-2026-24006 is a high-severity denial of service vulnerability in lxsmnsyc seroval, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Seroval facilitates JS value stringification, including complex structures beyond JSON.stringify capabilities. In versions 1.4.0
and below, serialization of objects with extreme depth can exceed the maximum call stack limit. In version 1.4.1, Seroval introduces a `depthLimit` parameter in serialization/deserialization methods. An error will be thrown if the depth limit is reached.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-24006?

2 open source packages ship an affected version, including seroval. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `seroval` | npm | All versions | 1.4.1 |
| `seroval` | npm | All versions | 1.4.1 |

Products: Lxsmnsyc Seroval.

## How do I fix CVE-2026-24006?

Upgrade seroval to 1.4.1 or later.

## Is CVE-2026-24006 being exploited?

There is no known exploitation of CVE-2026-24006 in the wild and no public exploit code.

## Other vulnerabilities in lxsmnsyc seroval

- [CVE-2026-23956](https://insights.sbomify.com/CVE-2026-23956/): seroval affected by Denial of Service via RegExp serialization (high 7.5)
- [CVE-2026-23957](https://insights.sbomify.com/CVE-2026-23957/): seroval is vulnerable to Denial of Service via array serialization (high 7.5)
- [CVE-2026-23737](https://insights.sbomify.com/CVE-2026-23737/): seroval Affected by Remote Code Execution via JSON Deserialization (high 7.5)
- [CVE-2026-23736](https://insights.sbomify.com/CVE-2026-23736/): seroval Affected by Prototype Pollution via JSON Deserialization (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24006 and fix it if it is affected.

What it is: CVE-2026-24006 is a high-severity denial of service vulnerability in lxsmnsyc seroval, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24006 in the wild and no public exploit code.

Affected packages and fixed versions:
- seroval (npm): affected all versions; fixed in 1.4.1
- seroval (npm): affected all versions; fixed in 1.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24006/ (Markdown: https://insights.sbomify.com/CVE-2026-24006/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24006
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24006
- OSV: https://osv.dev/vulnerability/CVE-2026-24006

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24006/
Summaries are generated and may contain mistakes; the official description above is the record.
