CVE-2026-24009 Docling Core vulnerable to Remote Code Execution via unsafe PyYAML usage
Attackers can execute arbitrary code via unsafe YAML deserialization in Docling Core when processing untrusted data with vulnerable PyYAML versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-24009?
CVE-2026-24009 is a high-severity unsafe deserialization vulnerability in docling-project docling-core, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Docling Core (or docling-core) is a library that defines core data types and transformations in the document processing application Docling. A PyYAML-related Remote Code Execution (RCE) vulnerability, namely CVE-2020-14343, is exposed in docling-core starting in version 2.21.0 and prior to version 2.48.4, specifically only if the application uses pyyaml prior to version 5.4 and invokes `docling_core.types.doc.DoclingDocument.load_from_yaml()` passing it untrusted YAML data. The vulnerability has been patched in docling-core version 2.48.4. The fix mitigates the issue by switching `PyYAML` deserialization from `yaml.FullLoader` to `yaml.SafeLoader`, ensuring that untrusted data cannot trigger code execution. Users who cannot immediately upgrade docling-core can alternatively ensure that the installed version of PyYAML is 5.4 or greater.
Weakness: CWE-502
Which versions are affected by CVE-2026-24009?
3 open source packages ship an affected version, including docling-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
docling-core PyPI | From 2.21.0 | 2.48.4 |
docling-core PyPI | From 2.21.0 | 2.48.4 |
docling-core PyPI | From 2.21.0 | 2.48.4 |
Products include Docling Docling-Core.
How do I fix CVE-2026-24009?
Upgrade docling-core to 2.48.4 or later.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2026-24009 being exploited?
There is no known exploitation of CVE-2026-24009 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in docling-project docling-core
Sources
Also known as GHSA-vqxf-v2gg-x3hc, PYSEC-2026-1313.