{"answers":{"affected":"3 open source packages ship an affected version, including docling-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-24009 in the wild and no public exploit code.","fix":"Upgrade docling-core to 2.48.4 or later.","what":"CVE-2026-24009 is a high-severity unsafe deserialization vulnerability in docling-project docling-core, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-24009 and fix it if it is affected.\n\nWhat it is: CVE-2026-24009 is a high-severity unsafe deserialization vulnerability in docling-project docling-core, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-24009 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- docling-core (PyPI): affected from 2.21.0; fixed in 2.48.4\n- docling-core (PyPI): affected from 2.21.0; fixed in 2.48.4\n- docling-core (PyPI): affected from 2.21.0; fixed in 2.48.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-24009/ (Markdown: https://insights.sbomify.com/CVE-2026-24009/index.md)","id":"CVE-2026-24009","markdown":"https://insights.sbomify.com/CVE-2026-24009/index.md","name":"CVE-2026-24009","record":{"aliases":["GHSA-vqxf-v2gg-x3hc","PYSEC-2026-1313"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Python document processing library","requires_auth":"none","summary":"Attackers can execute arbitrary code via unsafe YAML deserialization in Docling Core when processing untrusted data with vulnerable PyYAML versions.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"docling-core","vendor":"docling"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Docling Core (or docling-core) is a library that defines core data types and transformations in the document processing application Docling. A PyYAML-related Remote Code Execution (RCE) vulnerability, namely CVE-2020-14343, is exposed in docling-core starting in version 2.21.0 and prior to version 2.48.4, specifically only if the application uses pyyaml prior to version 5.4 and invokes `docling_core.types.doc.DoclingDocument.load_from_yaml()` passing it untrusted YAML data. The vulnerability has been patched in docling-core version 2.48.4. The fix mitigates the issue by switching `PyYAML` deserialization from `yaml.FullLoader` to `yaml.SafeLoader`, ensuring that untrusted data cannot trigger code execution. Users who cannot immediately upgrade docling-core can alternatively ensure that the installed version of PyYAML is 5.4 or greater.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2026-02-26","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-02-26T09:49:17Z","kind":"github_poc","ref":"https://github.com/BiranPeretz/docling-core-CVE-2026-24009","stars":0,"title":"Technical write-up and PoC for CVE-2026-24009, demonstrating unsafe YAML loading in docling-core and practical mitigation paths."}],"tier":"poc_unverified"},"has_fix":true,"headline":"Docling Core vulnerable to Remote Code Execution via unsafe PyYAML usage","id":"CVE-2026-24009","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":3,"n_references":5,"next":{"headline":"Horilla has HTML Injection Issue that, with Phishing, Leads to Account Takeover","id":"CVE-2026-24010"},"packages":[{"ecosystem":"PyPI","fixed":["2.48.4"],"introduced":["2.21.0"],"last_affected":[],"package":"docling-core","purl":null,"source":"GHSA-vqxf-v2gg-x3hc"},{"ecosystem":"PyPI","fixed":["2.48.4"],"introduced":["2.21.0"],"last_affected":[],"package":"docling-core","purl":"pkg:pypi/docling-core","source":"GHSA-vqxf-v2gg-x3hc"},{"ecosystem":"PyPI","fixed":["2.48.4"],"introduced":["2.21.0"],"last_affected":[],"package":"docling-core","purl":"pkg:pypi/docling-core","source":"PYSEC-2026-1313"}],"prev":{"headline":"Tuleap is missing CSRF protection in the Overview inconsistent items","id":"CVE-2026-24007"},"products":["docling-core"],"published":"2026-01-22","related":[{"cvss_score":8.6,"headline":"Docling Core has unsafe remote filename resolution","id":"CVE-2026-44023","kev_date_added":null,"published":"2026-07-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-22","vendors":["docling-project"]},"summary":"Attackers can execute arbitrary code via unsafe YAML deserialization in Docling Core when processing untrusted data with vulnerable PyYAML versions.","url":"https://insights.sbomify.com/CVE-2026-24009/"}