# CVE-2026-24009: Docling Core vulnerable to Remote Code Execution via unsafe PyYAML usage

> Attackers can execute arbitrary code via unsafe YAML deserialization in Docling Core when processing untrusted data with vulnerable PyYAML versions.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2026
- **Updated:** 22 Jan 2026
- **Also known as:** GHSA-vqxf-v2gg-x3hc, PYSEC-2026-1313

## What is CVE-2026-24009?

CVE-2026-24009 is a high-severity unsafe deserialization vulnerability in docling-project docling-core, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Docling Core (or docling-core) is a library that defines core data types and transformations in the document processing application Docling. A PyYAML-related Remote Code Execution (RCE) vulnerability, namely CVE-2020-14343, is exposed in docling-core starting in version 2.21.0 and prior to version 2.48.4, specifically only if the application uses pyyaml prior to version 5.4 and invokes `docling_core.types.doc.DoclingDocument.load_from_yaml()` passing it untrusted YAML data. The vulnerability has been patched in docling-core version 2.48.4. The fix mitigates the issue by switching `PyYAML` deserialization from `yaml.FullLoader` to `yaml.SafeLoader`, ensuring that untrusted data cannot trigger code execution. Users who cannot immediately upgrade docling-core can alternatively ensure that the installed version of PyYAML is 5.4 or greater.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-24009?

3 open source packages ship an affected version, including docling-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `docling-core` | PyPI | From 2.21.0 | 2.48.4 |
| `docling-core` | PyPI | From 2.21.0 | 2.48.4 |
| `docling-core` | PyPI | From 2.21.0 | 2.48.4 |

Products: Docling Docling-Core.

## How do I fix CVE-2026-24009?

Upgrade docling-core to 2.48.4 or later.

## Is CVE-2026-24009 being exploited?

There is no known exploitation of CVE-2026-24009 in the wild and no public exploit code.

Public exploit code:

- Technical write-up and PoC for CVE-2026-24009, demonstrating unsafe YAML loading in docling-core and practical mitigation paths. (github_poc): https://github.com/BiranPeretz/docling-core-CVE-2026-24009

## Other vulnerabilities in docling-project docling-core

- [CVE-2026-44023](https://insights.sbomify.com/CVE-2026-44023/): Docling Core has unsafe remote filename resolution (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24009 and fix it if it is affected.

What it is: CVE-2026-24009 is a high-severity unsafe deserialization vulnerability in docling-project docling-core, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24009 in the wild and no public exploit code.

Affected packages and fixed versions:
- docling-core (PyPI): affected from 2.21.0; fixed in 2.48.4
- docling-core (PyPI): affected from 2.21.0; fixed in 2.48.4
- docling-core (PyPI): affected from 2.21.0; fixed in 2.48.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24009/ (Markdown: https://insights.sbomify.com/CVE-2026-24009/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24009
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24009
- OSV: https://osv.dev/vulnerability/CVE-2026-24009

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24009/
Summaries are generated and may contain mistakes; the official description above is the record.
