# CVE-2026-24040: jsPDF has a Shared State Race Condition in addJS Plugin

> Concurrent requests in server-side environments may leak sensitive data between users due to shared state in the addJS plugin.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Feb 2026
- **Updated:** 3 Feb 2026
- **Also known as:** GHSA-cjw8-79x6-5cj4

## What is CVE-2026-24040?

CVE-2026-24040 is a medium-severity vulnerability in parallax jsPDF, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jsPDF is a library to generate PDFs in JavaScript. Prior to 4.1.0, the addJS method in the jspdf Node.js build utilizes a shared module-scoped variable (text) to store JavaScript content. When used in a concurrent environment (e.g., a Node.js web server), this variable is shared across all requests. If multiple requests generate PDFs simultaneously, the JavaScript content intended for one user may be overwritten by a subsequent request before the document is generated. This results in Cross-User Data Leakage, where the PDF generated for User A contains the JavaScript payload (and any embedded sensitive data) intended for User B. Typically, this only affects server-side environments, although the same race conditions might occur if jsPDF runs client-side. The vulnerability has been fixed in jsPDF@4.1.0.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2026-24040?

2 open source packages ship an affected version, including jspdf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jspdf` | npm | All versions | 4.1.0 |
| `jspdf` | npm | All versions | 4.1.0 |

Products: Parall Jspdf.

## How do I fix CVE-2026-24040?

Upgrade jspdf to 4.1.0 or later.

## Is CVE-2026-24040 being exploited?

There is no known exploitation of CVE-2026-24040 in the wild and no public exploit code.

## Other vulnerabilities in parallax jsPDF

- [CVE-2026-31938](https://insights.sbomify.com/CVE-2026-31938/): jsPDF has HTML Injection in New Window paths (critical 9.6)
- [CVE-2025-68428](https://insights.sbomify.com/CVE-2025-68428/): jsPDF has Local File Inclusion/Path Traversal vulnerability (critical 9.2)
- [CVE-2026-25535](https://insights.sbomify.com/CVE-2026-25535/): jsPDF Affected by Client-Side/Server-Side Denial of Service via Malicious GIF Dimensions (high 8.7)
- [CVE-2026-24133](https://insights.sbomify.com/CVE-2026-24133/): jsPDF Affected by Denial of Service (DoS) via Unvalidated BMP Dimensions in BMPDecoder (high 8.7)
- [CVE-2025-57810](https://insights.sbomify.com/CVE-2025-57810/): jsPDF Parsing of Corrupt PNGs Leads to Potential Denial of Service (DoS) (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24040 and fix it if it is affected.

What it is: CVE-2026-24040 is a medium-severity vulnerability in parallax jsPDF, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24040 in the wild and no public exploit code.

Affected packages and fixed versions:
- jspdf (npm): affected all versions; fixed in 4.1.0
- jspdf (npm): affected all versions; fixed in 4.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24040/ (Markdown: https://insights.sbomify.com/CVE-2026-24040/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24040
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24040
- OSV: https://osv.dev/vulnerability/CVE-2026-24040

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24040/
Summaries are generated and may contain mistakes; the official description above is the record.
