CVE-2026-24048 Backstage has a Possible SSRF when reading from allowed URL's in `backend.reading.allow`
Attackers can bypass URL allowlists via HTTP redirects to access internal resources in Backstage developer portals.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-24048?
CVE-2026-24048 is a low-severity server-side request forgery vulnerability in backstage, published on 21 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Backstage is an open framework for building developer portals, and @backstage/backend-defaults provides the default implementations and setup for a standard Backstage backend app. Prior to versions 0.12.2, 0.13.2, 0.14.1, and 0.15.0, the `FetchUrlReader` component, used by the catalog and other plugins to fetch content from URLs, followed HTTP redirects automatically. This allowed an attacker who controls a host listed in `backend.reading.allow` to redirect requests to internal or sensitive URLs that are not on the allowlist, bypassing the URL allowlist security control. This is a Server-Side Request Forgery (SSRF) vulnerability that could allow access to internal resources, but it does not allow attackers to include additional request headers. This vulnerability is fixed in `@backstage/backend-defaults` version 0.12.2, 0.13.2, 0.14.1, and 0.15.0. Users should upgrade to this version or later. Some workarounds are available. Restrict `backend.reading.allow` to only trusted hosts that you control and that do not issue redirects, ensure allowed hosts do not have open redirect vulnerabilities, and/or use network-level controls to block access from Backstage to sensitive internal endpoints.
Weakness: CWE-918
Which versions are affected by CVE-2026-24048?
6 open source packages ship an affected version, including @backstage/backend-defaults. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
@backstage/backend-defaults npm | All versions | 0.12.2 |
@backstage/backend-defaults npm | All versions | 0.12.2 |
@backstage/backend-defaults npm | From 0.13.0 | 0.13.2 |
@backstage/backend-defaults npm | From 0.13.0 | 0.13.2 |
@backstage/backend-defaults npm | From 0.14.0 | 0.14.1 |
@backstage/backend-defaults npm | From 0.14.0 | 0.14.1 |
Products include Linuxfoundation Backstage\/Backend Defaults.
How do I fix CVE-2026-24048?
Upgrade @backstage/backend-defaults to a fixed version for your release line: 0.12.2, 0.13.2 or 0.14.1.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2026-24048 being exploited?
There is no known exploitation of CVE-2026-24048 in the wild and no public exploit code.
Sources
Also known as GHSA-q2x5-4xjx-c6p9.