{"answers":{"affected":"6 open source packages ship an affected version, including @backstage/backend-defaults. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-24048 in the wild and no public exploit code.","fix":"Upgrade @backstage/backend-defaults to a fixed version for your release line: 0.12.2, 0.13.2 or 0.14.1.","what":"CVE-2026-24048 is a low-severity server-side request forgery vulnerability in backstage, published on 21 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-24048 and fix it if it is affected.\n\nWhat it is: CVE-2026-24048 is a low-severity server-side request forgery vulnerability in backstage, published on 21 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-24048 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @backstage/backend-defaults (npm): affected all versions; fixed in 0.12.2\n- @backstage/backend-defaults (npm): affected all versions; fixed in 0.12.2\n- @backstage/backend-defaults (npm): affected from 0.13.0; fixed in 0.13.2\n- @backstage/backend-defaults (npm): affected from 0.13.0; fixed in 0.13.2\n- @backstage/backend-defaults (npm): affected from 0.14.0; fixed in 0.14.1\n- @backstage/backend-defaults (npm): affected from 0.14.0; fixed in 0.14.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-24048/ (Markdown: https://insights.sbomify.com/CVE-2026-24048/index.md)","id":"CVE-2026-24048","markdown":"https://insights.sbomify.com/CVE-2026-24048/index.md","name":"CVE-2026-24048","record":{"aliases":["GHSA-q2x5-4xjx-c6p9"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Backstage developer portal","requires_auth":"low_privilege","summary":"Attackers can bypass URL allowlists via HTTP redirects to access internal resources in Backstage developer portals.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"backstage\\/backend_defaults","vendor":"linuxfoundation"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Backstage is an open framework for building developer portals, and @backstage/backend-defaults provides the default implementations and setup for a standard Backstage backend app. Prior to versions 0.12.2, 0.13.2, 0.14.1, and 0.15.0, the `FetchUrlReader` component, used by the catalog and other plugins to fetch content from URLs, followed HTTP redirects automatically. This allowed an attacker who controls a host listed in `backend.reading.allow` to redirect requests to internal or sensitive URLs that are not on the allowlist, bypassing the URL allowlist security control. This is a Server-Side Request Forgery (SSRF) vulnerability that could allow access to internal resources, but it does not allow attackers to include additional request headers. This vulnerability is fixed in `@backstage/backend-defaults` version 0.12.2, 0.13.2, 0.14.1, and 0.15.0. Users should upgrade to this version or later. Some workarounds are available. Restrict `backend.reading.allow` to only trusted hosts that you control and that do not issue redirects, ensure allowed hosts do not have open redirect vulnerabilities, and/or use network-level controls to block access from Backstage to sensitive internal endpoints.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Backstage has a Possible SSRF when reading from allowed URL's in `backend.reading.allow`","id":"CVE-2026-24048","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2026"},"n_packages":6,"n_references":2,"next":{"headline":"wheel Allows Arbitrary File Permission Modification via Path Traversal","id":"CVE-2026-24049"},"packages":[{"ecosystem":"npm","fixed":["0.12.2"],"introduced":["0"],"last_affected":[],"package":"@backstage/backend-defaults","purl":null,"source":"GHSA-q2x5-4xjx-c6p9"},{"ecosystem":"npm","fixed":["0.12.2"],"introduced":["0"],"last_affected":[],"package":"@backstage/backend-defaults","purl":"pkg:npm/%40backstage/backend-defaults","source":"GHSA-q2x5-4xjx-c6p9"},{"ecosystem":"npm","fixed":["0.13.2"],"introduced":["0.13.0"],"last_affected":[],"package":"@backstage/backend-defaults","purl":null,"source":"GHSA-q2x5-4xjx-c6p9"},{"ecosystem":"npm","fixed":["0.13.2"],"introduced":["0.13.0"],"last_affected":[],"package":"@backstage/backend-defaults","purl":"pkg:npm/%40backstage/backend-defaults","source":"GHSA-q2x5-4xjx-c6p9"},{"ecosystem":"npm","fixed":["0.14.1"],"introduced":["0.14.0"],"last_affected":[],"package":"@backstage/backend-defaults","purl":null,"source":"GHSA-q2x5-4xjx-c6p9"},{"ecosystem":"npm","fixed":["0.14.1"],"introduced":["0.14.0"],"last_affected":[],"package":"@backstage/backend-defaults","purl":"pkg:npm/%40backstage/backend-defaults","source":"GHSA-q2x5-4xjx-c6p9"}],"prev":{"headline":"@backstage/cli-common has a possible `resolveSafeChildPath` Symlink Chain Bypass","id":"CVE-2026-24047"},"products":["backstage"],"published":"2026-01-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-22","vendors":["backstage"]},"summary":"Attackers can bypass URL allowlists via HTTP redirects to access internal resources in Backstage developer portals.","url":"https://insights.sbomify.com/CVE-2026-24048/"}