# CVE-2026-24048: Backstage has a Possible SSRF when reading from allowed URL's in `backend.reading.allow`

> Attackers can bypass URL allowlists via HTTP redirects to access internal resources in Backstage developer portals.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jan 2026
- **Updated:** 22 Jan 2026
- **Also known as:** GHSA-q2x5-4xjx-c6p9

## What is CVE-2026-24048?

CVE-2026-24048 is a low-severity server-side request forgery vulnerability in backstage, published on 21 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Backstage is an open framework for building developer portals, and @backstage/backend-defaults provides the default implementations and setup for a standard Backstage backend app. Prior to versions 0.12.2, 0.13.2, 0.14.1, and 0.15.0, the `FetchUrlReader` component, used by the catalog and other plugins to fetch content from URLs, followed HTTP redirects automatically. This allowed an attacker who controls a host listed in `backend.reading.allow` to redirect requests to internal or sensitive URLs that are not on the allowlist, bypassing the URL allowlist security control. This is a Server-Side Request Forgery (SSRF) vulnerability that could allow access to internal resources, but it does not allow attackers to include additional request headers. This vulnerability is fixed in `@backstage/backend-defaults` version 0.12.2, 0.13.2, 0.14.1, and 0.15.0. Users should upgrade to this version or later. Some workarounds are available. Restrict `backend.reading.allow` to only trusted hosts that you control and that do not issue redirects, ensure allowed hosts do not have open redirect vulnerabilities, and/or use network-level controls to block access from Backstage to sensitive internal endpoints.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-24048?

6 open source packages ship an affected version, including @backstage/backend-defaults. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/backend-defaults` | npm | All versions | 0.12.2 |
| `@backstage/backend-defaults` | npm | All versions | 0.12.2 |
| `@backstage/backend-defaults` | npm | From 0.13.0 | 0.13.2 |
| `@backstage/backend-defaults` | npm | From 0.13.0 | 0.13.2 |
| `@backstage/backend-defaults` | npm | From 0.14.0 | 0.14.1 |
| `@backstage/backend-defaults` | npm | From 0.14.0 | 0.14.1 |

Products: Linuxfoundation Backstage\/Backend Defaults.

## How do I fix CVE-2026-24048?

Upgrade @backstage/backend-defaults to a fixed version for your release line: 0.12.2, 0.13.2 or 0.14.1.

## Is CVE-2026-24048 being exploited?

There is no known exploitation of CVE-2026-24048 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24048 and fix it if it is affected.

What it is: CVE-2026-24048 is a low-severity server-side request forgery vulnerability in backstage, published on 21 Jan 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24048 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/backend-defaults (npm): affected all versions; fixed in 0.12.2
- @backstage/backend-defaults (npm): affected all versions; fixed in 0.12.2
- @backstage/backend-defaults (npm): affected from 0.13.0; fixed in 0.13.2
- @backstage/backend-defaults (npm): affected from 0.13.0; fixed in 0.13.2
- @backstage/backend-defaults (npm): affected from 0.14.0; fixed in 0.14.1
- @backstage/backend-defaults (npm): affected from 0.14.0; fixed in 0.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24048/ (Markdown: https://insights.sbomify.com/CVE-2026-24048/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24048
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24048
- OSV: https://osv.dev/vulnerability/CVE-2026-24048

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24048/
Summaries are generated and may contain mistakes; the official description above is the record.
