# CVE-2026-24056: pnpm has symlink traversal in file:/git dependencies

> Attackers can leak local sensitive files by installing malicious file or git dependencies containing symlinks, affecting developers and CI/CD pipelines.

- **Severity:** Medium 6.7 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jan 2026
- **Updated:** 27 Jan 2026
- **Also known as:** GHSA-m733-5w8f-5ggw, MINI-658w-5hm9-65qp

## What is CVE-2026-24056?

CVE-2026-24056 is a medium-severity path traversal vulnerability in pnpm, published on 26 Jan 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

pnpm is a package manager. Prior to version 10.28.2, when pnpm installs a `file:` (directory) or `git:` dependency, it follows symlinks and reads their target contents without constraining them to the package root. A malicious package containing a symlink to an absolute path (e.g., `/etc/passwd`, `~/.ssh/id_rsa`) causes pnpm to copy that file's contents into `node_modules`, leaking local data. The vulnerability only affects `file:` and `git:` dependencies. Registry packages (npm) have symlinks stripped during publish and are NOT affected. The issue impacts developers installing local/file dependencies andCI/CD pipelines installing git dependencies. It can lead to credential theft via symlinks to `~/.aws/credentials`, `~/.npmrc`, `~/.ssh/id_rsa`. Version 10.28.2 contains a patch.

Weakness: CWE-59 (Improper Link Resolution Before File Access), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-24056?

2 open source packages ship an affected version, including pnpm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pnpm` | npm | All versions | 10.28.2 |
| `pnpm` | npm | All versions | 10.28.2 |

Products: Pnpm Pnpm.

## How do I fix CVE-2026-24056?

Upgrade pnpm to 10.28.2 or later.

## Is CVE-2026-24056 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24056 exists.

## Other vulnerabilities in pnpm

- [CVE-2026-50016](https://insights.sbomify.com/CVE-2026-50016/): pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement (high 8.8)
- [CVE-2026-55698](https://insights.sbomify.com/CVE-2026-55698/): pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes (high 8.8)
- [CVE-2025-69264](https://insights.sbomify.com/CVE-2025-69264/): pnpm v10+ Bypass "Dependency lifecycle scripts execution disabled by default" (high 8.8)
- [CVE-2022-26183](https://insights.sbomify.com/CVE-2022-26183/): Untrusted Search Path in PNPM (high 8.8)
- [CVE-2026-59195](https://insights.sbomify.com/CVE-2026-59195/): pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24056 and fix it if it is affected.

What it is: CVE-2026-24056 is a medium-severity path traversal vulnerability in pnpm, published on 26 Jan 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24056 exists.

Affected packages and fixed versions:
- pnpm (npm): affected all versions; fixed in 10.28.2
- pnpm (npm): affected all versions; fixed in 10.28.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24056/ (Markdown: https://insights.sbomify.com/CVE-2026-24056/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24056
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24056
- OSV: https://osv.dev/vulnerability/CVE-2026-24056

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24056/
Summaries are generated and may contain mistakes; the official description above is the record.
