# CVE-2026-24058: Soft Serve has Critical Authentication Bypass

> Attackers can impersonate any user, including admins, by exploiting an SSH handshake flaw in Soft Serve Git server.

- **Severity:** High 8.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2026
- **Updated:** 23 Jan 2026
- **Also known as:** GHSA-pchf-49fh-w34r, GO-2026-4353

## What is CVE-2026-24058?

CVE-2026-24058 is a high-severity authentication bypass vulnerability in charmbracelet soft-serve, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Soft Serve is a self-hostable Git server for the command line. Versions 0.11.2 and below have a critical authentication bypass vulnerability that allows an attacker to impersonate any user (including admin) by "offering" the victim's public key during the SSH handshake before authenticating with their own valid key. This occurs because the user identity is stored in the session context during the "offer" phase and is not cleared if that specific authentication attempt fails. This issue has been fixed in version 0.11.3.

Weakness: CWE-289 (Authentication Bypass by Alternate Name)

## Which versions are affected by CVE-2026-24058?

3 open source packages ship an affected version, including github.com/charmbracelet/soft-serve. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/charmbracelet/soft-serve` | Go | All versions | 0.11.3 |
| `github.com/charmbracelet/soft-serve` | Go | All versions | 0.11.3 |
| `github.com/charmbracelet/soft-serve` | Go | All versions | 0.11.3 |

Products: Charm Soft Serve.

## How do I fix CVE-2026-24058?

Upgrade github.com/charmbracelet/soft-serve to 0.11.3 or later.

## Is CVE-2026-24058 being exploited?

There is no known exploitation of CVE-2026-24058 in the wild and no public exploit code.

## Other vulnerabilities in charmbracelet soft-serve

- [CVE-2026-30832](https://insights.sbomify.com/CVE-2026-30832/): Soft Serve: SSRF via unvalidated LFS endpoint in repo import (critical 9.1)
- [CVE-2025-64522](https://insights.sbomify.com/CVE-2025-64522/): Soft Serve is vulnerable to SSRF through its Webhooks (critical 9.1)
- [CVE-2023-43809](https://insights.sbomify.com/CVE-2023-43809/): Soft Serve Public Key Authentication Bypass Vulnerability when Keyboard-Interactive SSH Authentication is Enabled (high 7.5)
- [CVE-2026-33353](https://insights.sbomify.com/CVE-2026-33353/): Soft Serve: Authenticated repo import can clone server-local private repositories (high 7.1)
- [CVE-2026-22253](https://insights.sbomify.com/CVE-2026-22253/): Soft Serve is missing an authorization check in LFS lock deletion (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24058 and fix it if it is affected.

What it is: CVE-2026-24058 is a high-severity authentication bypass vulnerability in charmbracelet soft-serve, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24058 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.11.3
- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.11.3
- github.com/charmbracelet/soft-serve (Go): affected all versions; fixed in 0.11.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24058/ (Markdown: https://insights.sbomify.com/CVE-2026-24058/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24058
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24058
- OSV: https://osv.dev/vulnerability/CVE-2026-24058

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24058/
Summaries are generated and may contain mistakes; the official description above is the record.
