# CVE-2026-24065: Local Privilege Escalation via Insecure XPC Client Validation in Waves Central for macOS

> A local attacker can exploit a race condition in Waves Central's XPC validation to execute arbitrary code with root privileges on macOS.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Jun 2026
- **Updated:** 9 Jun 2026
- **Also known as:** GHSA-hmpm-h2c9-p557

## What is CVE-2026-24065?

CVE-2026-24065 is a high-severity vulnerability in Waves Central, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Waves Central for macOS versions 13.0.9 through 16.5.5 contain a local privilege escalation vulnerability in the privileged helper service. The helper validates connecting XPC clients using the client process identifier (PID) to verify code-signing identity. Because process identifiers can be reused, a local attacker can exploit a race condition between the time a connection request is made and the time the helper performs validation, causing the helper to trust an attacker-controlled process. This allows the attacker to invoke privileged operations, resulting in arbitrary code execution as root. The issue is fixed in version 16.6.2.

Weakness: CWE-367 (Time-of-check Time-of-use (TOCTOU) Race Condition)

## Which versions are affected by CVE-2026-24065?


## How do I fix CVE-2026-24065?

No fix has been published for CVE-2026-24065 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-24065 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24065 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24065 and fix it if it is affected.

What it is: CVE-2026-24065 is a high-severity vulnerability in Waves Central, published on 9 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24065 exists.

Affected product: Waves Central. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24065/ (Markdown: https://insights.sbomify.com/CVE-2026-24065/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24065
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24065
- OSV: https://osv.dev/vulnerability/CVE-2026-24065

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24065/
Summaries are generated and may contain mistakes; the official description above is the record.
