CVE-2026-24072 Apache HTTP Server: mod_rewrite elevation of privileges via ap_expr

High 8.8 Published Updated

Local .htaccess authors can escalate privileges to read files as the httpd user in Apache HTTP Server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-24072?

CVE-2026-24072 is a high-severity vulnerability in Apache Http Server, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An escalation of privilege bug in various modules in Apache HTTP 2.4.66 and earlier allows local .htaccess authors to read files with the privileges of the httpd user.

Users are recommended to upgrade to version 2.4.67, which fixes this issue.

Weakness: CWE-269

Which versions are affected by CVE-2026-24072?

1 open source package ship an affected version, including apache. It affects 1 product.

PackageAffectedFixed in
apache BitnamiAll versions2.4.67

Products include Apache Http Server.

How do I fix CVE-2026-24072?

Upgrade apache to 2.4.67 or later.

Is CVE-2026-24072 being exploited?

There is no known exploitation of CVE-2026-24072 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Apache Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2026-24072, AZL-85998, BELL-CVE-2026-24072, BIT-apache-2026-24072, DEBIAN-CVE-2026-24072, GHSA-9pw3-5ggm-c92r and 1 more.

Is CVE-2026-24072 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free