{"answers":{"affected":"1 open source package ship an affected version, including apache. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-24072 in the wild and no public exploit code.","fix":"Upgrade apache to 2.4.67 or later.","what":"CVE-2026-24072 is a high-severity vulnerability in Apache Http Server, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-24072 and fix it if it is affected.\n\nWhat it is: CVE-2026-24072 is a high-severity vulnerability in Apache Http Server, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-24072 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache (Bitnami): affected all versions; fixed in 2.4.67\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-24072/ (Markdown: https://insights.sbomify.com/CVE-2026-24072/index.md)","id":"CVE-2026-24072","markdown":"https://insights.sbomify.com/CVE-2026-24072/index.md","name":"CVE-2026-24072","record":{"aliases":["ALPINE-CVE-2026-24072","AZL-85998","BELL-CVE-2026-24072","BIT-apache-2026-24072","DEBIAN-CVE-2026-24072","GHSA-9pw3-5ggm-c92r","MINI-7c3h-fjv5-5hrf"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache HTTP Server","requires_auth":"low_privilege","summary":"Local .htaccess authors can escalate privileges to read files as the httpd user in Apache HTTP Server.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"http_server","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"An escalation of privilege bug in various modules in Apache HTTP 2.4.66 and earlier allows local .htaccess authors to read files with the privileges of the httpd user.\n\nUsers are recommended to upgrade to version 2.4.67, which fixes this issue.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":"2026-05-05","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-05-05T18:48:29Z","kind":"github_poc","ref":"https://github.com/meh098/CVE-2026-24072-Analysis","stars":0,"title":"Analysis of CVE-2026-24072"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Apache HTTP Server: mod_rewrite elevation of privileges via ap_expr","id":"CVE-2026-24072","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:http_server","products":["apache:http_server"],"type":"privilege_escalation","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Out-of-bounds Write in Video","id":"CVE-2026-24073"},"packages":[{"ecosystem":"Bitnami","fixed":["2.4.67"],"introduced":["0"],"last_affected":[],"package":"apache","purl":"pkg:bitnami/apache","source":"BIT-apache-2026-24072"}],"prev":{"headline":"XPC Client Validation via PID leading to Local Privilege Escalation in Native Instruments Native Access","id":"CVE-2026-24071"},"products":["Apache HTTP Server"],"published":"2026-05-04","related":[{"cvss_score":9.8,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-42013","kev_date_added":"2021-11-03","published":"2021-10-07"},{"cvss_score":9.1,"headline":"Apache HTTP Server Improper Escaping of Output","id":"CVE-2024-38475","kev_date_added":"2025-05-01","published":"2024-07-01"},{"cvss_score":9,"headline":"Apache HTTP Server-Side Request Forgery (SSRF)","id":"CVE-2021-40438","kev_date_added":"2021-12-01","published":"2021-09-16"},{"cvss_score":7.8,"headline":"Apache HTTP Server Privilege Escalation","id":"CVE-2019-0211","kev_date_added":"2021-11-03","published":"2019-04-08"},{"cvss_score":7.5,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-41773","kev_date_added":"2021-11-03","published":"2021-10-05"},{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2010-0425","kev_date_added":null,"published":"2010-03-05"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2005-2700","kev_date_added":null,"published":"2005-09-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-05","vendors":["Apache Software Foundation"]},"summary":"Local .htaccess authors can escalate privileges to read files as the httpd user in Apache HTTP Server.","url":"https://insights.sbomify.com/CVE-2026-24072/"}