CVE-2026-24098 Apache Airflow: Assigning single DAG permission leaked all DAGs Import Errors

Medium 6.5 Published Updated

Authenticated users with limited DAG permissions can view import errors from unauthorized DAGs, exposing sensitive information.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-24098?

CVE-2026-24098 is a medium-severity vulnerability in Apache Airflow, published on 9 Feb 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to.

Users are advised to upgrade to 3.1.7 or later, which resolves this issue

Weakness: CWE-200

Which versions are affected by CVE-2026-24098?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.

PackageAffectedFixed in
apache-airflow PyPIAll versions3.1.7
apache-airflow PyPIAll versions3.1.7
apache-airflow PyPIFrom 3.0.03.1.7
airflow BitnamiAll versions3.1.7

Products include Apache Airflow.

How do I fix CVE-2026-24098?

Upgrade apache-airflow to 3.1.7 or later.

Is CVE-2026-24098 being exploited?

There is no known exploitation of CVE-2026-24098 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2026-24098, ECHO-a73b-1767-0d7f, GHSA-5g2w-9f8g-g5q7, MINI-fqfh-37wx-x88p, MINI-rffg-fq8x-r9pq, PYSEC-2026-12.

Is CVE-2026-24098 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free