# CVE-2026-24122: Cosign Certificate Chain Expiry Validation Issue Allows Issuing Certificate Expiry to Be Overlooked

> Attackers can bypass certificate expiry checks in private Cosign deployments, allowing expired issuing certificates to validate signatures.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Feb 2026
- **Updated:** 20 Feb 2026
- **Also known as:** BIT-cosign-2026-24122, CLEANSTART-2026-FA45866, DEBIAN-CVE-2026-24122, GHSA-wfqv-66vq-46rm, GO-2026-4529, MINI-297f-vwqh-3p5h, MINI-2fw2-hhc7-qjm2, MINI-37f2-pp2p-q95c, MINI-38x8-8hh2-m5h7, MINI-6cxj-m4m3-j2mh, MINI-738c-gp86-hhqg, MINI-78j4-2m23-xq2f, MINI-8xxp-vpq5-h96m, MINI-932v-p588-rx58, MINI-c25r-pwhh-8p4h, MINI-c493-p9jq-pjxf, MINI-cm8x-3jpx-jmpq, MINI-f797-95p2-w787, MINI-fgg7-c4f9-77m7, MINI-fv6x-q7gg-c35f, MINI-fvj4-c69x-5r28, MINI-gqrc-c7wm-rmg5, MINI-hr98-jv4m-ggw5, MINI-j4pj-359m-m9hx, MINI-jc3m-pjqw-pg85, MINI-mjq4-pwq9-6x2c, MINI-pw4c-qfq5-x2hc, MINI-pxg6-jqm4-8q53, MINI-q89c-9whh-c8rc, MINI-rhhv-78xq-23r2, MINI-rm7m-p4cw-ww83, MINI-vqrq-hp34-f8f4, MINI-vx59-2wg2-qh37, MINI-wg83-6pqr-5xh7, MINI-xm84-wrjr-p8pf, MINI-xm93-32wj-wh4p, MINI-xw8m-g9c5-6ccw, UBUNTU-CVE-2026-24122, openSUSE-SU-2026:10635-1, openSUSE-SU-2026:20662-1

## What is CVE-2026-24122?

CVE-2026-24122 is a low-severity vulnerability in sigstore cosign, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cosign provides code signing and transparency for containers and binaries. In versions 3.0.4 and below, an issuing certificate with a validity that expires before the leaf certificate will be considered valid during verification even if the provided timestamp would mean the issuing certificate should be considered expired. When verifying artifact signatures using a certificate, Cosign first verifies the certificate chain using the leaf certificate's "not before" timestamp and later checks expiry of the leaf certificate using either a signed timestamp provided by the Rekor transparency log or from a timestamp authority, or using the current time. The root and all issuing certificates are assumed to be valid during the leaf certificate's validity. There is no impact to users of the public Sigstore infrastructure. This may affect private deployments with customized PKIs. This issue has been fixed in version 3.0.5.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-24122?

6 open source packages ship an affected version, including github.com/sigstore/cosign, cosign and github.com/sigstore/cosign/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/sigstore/cosign` | Go | All versions | None |
| `github.com/sigstore/cosign` | Go | All versions | 3.0.5 |
| `github.com/sigstore/cosign` | Go | All versions | 3.0.5 |
| `cosign` | Bitnami | All versions | 3.0.5 |
| `github.com/sigstore/cosign/v2` | Go | All versions | None |
| `github.com/sigstore/cosign/v3` | Go | All versions | 3.0.5 |
| `hauler` | openSUSE:Tumbleweed | All versions | 1.4.2-1.1 |

Products: Sigstore Cosign.

## How do I fix CVE-2026-24122?

Upgrade github.com/sigstore/cosign to 3.0.5 or later.

## Is CVE-2026-24122 being exploited?

There is no known exploitation of CVE-2026-24122 in the wild and no public exploit code.

## Other vulnerabilities in sigstore cosign

- [CVE-2022-35929](https://insights.sbomify.com/CVE-2022-35929/): False positive signature verification in cosign (high 7.1)
- [CVE-2026-22703](https://insights.sbomify.com/CVE-2026-22703/): Cosign verification accepts any valid Rekor entry under certain conditions (medium 5.5)
- [CVE-2022-36056](https://insights.sbomify.com/CVE-2022-36056/): Vulnerabilities with blob verification in sigstore cosign (medium 5.5)
- [CVE-2026-39395](https://insights.sbomify.com/CVE-2026-39395/): Cosign's verify-blob-attestation reports false positive when payload parsing fails (medium 4.3)
- [CVE-2024-29902](https://insights.sbomify.com/CVE-2024-29902/): Cosign vulnerable to system-wide denial of service via malicious attachments (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24122 and fix it if it is affected.

What it is: CVE-2026-24122 is a low-severity vulnerability in sigstore cosign, published on 19 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24122 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/sigstore/cosign (Go): affected all versions; no fix listed
- github.com/sigstore/cosign (Go): affected all versions; fixed in 3.0.5
- github.com/sigstore/cosign (Go): affected all versions; fixed in 3.0.5
- cosign (Bitnami): affected all versions; fixed in 3.0.5
- github.com/sigstore/cosign/v2 (Go): affected all versions; no fix listed
- github.com/sigstore/cosign/v3 (Go): affected all versions; fixed in 3.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24122/ (Markdown: https://insights.sbomify.com/CVE-2026-24122/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24122
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24122
- OSV: https://osv.dev/vulnerability/CVE-2026-24122

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24122/
Summaries are generated and may contain mistakes; the official description above is the record.
