# CVE-2026-24123: BentoML has a Path Traversal via Bentofile Configuration

> Attackers can craft malicious Bentofile configurations to exfiltrate sensitive files into AI model archives, enabling supply chain attacks.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jan 2026
- **Updated:** 27 Jan 2026
- **Also known as:** GHSA-6r62-w2q3-48hf, PYSEC-2026-1218

## What is CVE-2026-24123?

CVE-2026-24123 is a high-severity path traversal vulnerability in BentoML, published on 26 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

BentoML is a Python library for building online serving systems optimized for AI apps and model inference. Prior to version 1.4.34, BentoML's `bentofile.yaml` configuration allows path traversal attacks through multiple file path fields (`description`, `docker.setup_script`, `docker.dockerfile_template`, `conda.environment_yml`). An attacker can craft a malicious bentofile that, when built by a victim, exfiltrates arbitrary files from the filesystem into the bento archive. This enables supply chain attacks where sensitive files (SSH keys, credentials, environment variables) are silently embedded in bentos and exposed when pushed to registries or deployed. Version 1.4.34 contains a patch for the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-24123?

3 open source packages ship an affected version, including bentoml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bentoml` | PyPI | All versions | 1.4.34 |
| `bentoml` | PyPI | All versions | 1.4.34 |
| `bentoml` | PyPI | All versions | 1.4.34 |

Products: Bentoml Bentoml.

## How do I fix CVE-2026-24123?

Upgrade bentoml to 1.4.34 or later.

## Is CVE-2026-24123 being exploited?

There is no known exploitation of CVE-2026-24123 in the wild and no public exploit code.

## Other vulnerabilities in BentoML

- [CVE-2025-54381](https://insights.sbomify.com/CVE-2025-54381/): BentoML is Vulnerable to an SSRF Attack Through File Upload Processing (critical 9.9)
- [CVE-2025-32375](https://insights.sbomify.com/CVE-2025-32375/): Insecure Deserialization leads to RCE in BentoML's runner server (critical 9.8)
- [CVE-2025-27520](https://insights.sbomify.com/CVE-2025-27520/): BentoML Allows Remote Code Execution (RCE) via Insecure Deserialization (critical 9.8)
- [CVE-2026-44345](https://insights.sbomify.com/CVE-2026-44345/): BentoML: Dockerfile command injection via docker.base_image (high 8.8)
- [CVE-2026-44346](https://insights.sbomify.com/CVE-2026-44346/): BentoML: Dockerfile command injection via envs[*].name in bentofile.yaml (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24123 and fix it if it is affected.

What it is: CVE-2026-24123 is a high-severity path traversal vulnerability in BentoML, published on 26 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-24123 in the wild and no public exploit code.

Affected packages and fixed versions:
- bentoml (PyPI): affected all versions; fixed in 1.4.34
- bentoml (PyPI): affected all versions; fixed in 1.4.34
- bentoml (PyPI): affected all versions; fixed in 1.4.34

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24123/ (Markdown: https://insights.sbomify.com/CVE-2026-24123/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24123
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24123
- OSV: https://osv.dev/vulnerability/CVE-2026-24123

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24123/
Summaries are generated and may contain mistakes; the official description above is the record.
