# CVE-2026-24124: Dragonfly Manager Job API Allows Unauthenticated Access

> Unauthenticated users can view, update, and delete jobs in Dragonfly Manager due to missing authentication and authorization checks on Job API endpoints.

- **Severity:** High 8.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-j8hf-cp34-g4j7, GO-2026-4356

## What is CVE-2026-24124?

CVE-2026-24124 is a high-severity missing authorization vulnerability in dragonflyoss dragonfly, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Dragonfly is an open source P2P-based file distribution and image acceleration system. In versions 2.4.1-rc.0 and below, the Job API endpoints (/api/v1/jobs) lack JWT authentication middleware and RBAC authorization checks in the routing configuration. This allows any unauthenticated user with access to the Manager API to view, update and delete jobs. The issue is fixed in version 2.4.1-rc.1.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2026-24124?

3 open source packages ship an affected version, including d7y.io/dragonfly/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `d7y.io/dragonfly/v2` | Go | All versions | 2.4.1 |
| `d7y.io/dragonfly/v2` | Go | All versions | 2.4.1 |
| `d7y.io/dragonfly/v2` | Go | All versions | 2.4.1 |

Products: Linuxfoundation Dragonfly.

## How do I fix CVE-2026-24124?

Upgrade d7y.io/dragonfly/v2 to 2.4.1 or later.

## Is CVE-2026-24124 being exploited?

There is no known exploitation of CVE-2026-24124 in the wild and no public exploit code.

## Other vulnerabilities in dragonflyoss dragonfly

- [CVE-2023-27584](https://insights.sbomify.com/CVE-2023-27584/): Dragonfly2 vulnerable to hard coded cyptographic key (critical 9.8)
- [CVE-2025-59345](https://insights.sbomify.com/CVE-2025-59345/): Dragonfly did not enable authentication for some Manager’s endpoints (high 7.7)
- [CVE-2025-59353](https://insights.sbomify.com/CVE-2025-59353/): Manager generates mTLS certificates for arbitrary IP addresses (high 7.7)
- [CVE-2025-59352](https://insights.sbomify.com/CVE-2025-59352/): Dragonfly allows arbitrary file read and write on a peer machine (medium 6.9)
- [CVE-2025-59346](https://insights.sbomify.com/CVE-2025-59346/): Dragonfly server-side request forgery vulnerability (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24124 and fix it if it is affected.

What it is: CVE-2026-24124 is a high-severity missing authorization vulnerability in dragonflyoss dragonfly, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24124 in the wild and no public exploit code.

Affected packages and fixed versions:
- d7y.io/dragonfly/v2 (Go): affected all versions; fixed in 2.4.1
- d7y.io/dragonfly/v2 (Go): affected all versions; fixed in 2.4.1
- d7y.io/dragonfly/v2 (Go): affected all versions; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24124/ (Markdown: https://insights.sbomify.com/CVE-2026-24124/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24124
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24124
- OSV: https://osv.dev/vulnerability/CVE-2026-24124

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24124/
Summaries are generated and may contain mistakes; the official description above is the record.
