CVE-2026-24128 XWiki Affected by Reflected Cross-Site Scripting (XSS) in Error Messages
Attackers can execute arbitrary scripts via malicious URLs, potentially gaining full administrative access to the XWiki installation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-24128?
CVE-2026-24128 is a medium-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 23 Jan 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Versions 7.0-milestone-2 through 16.10.11, 17.0.0-rc-1 through 17.4.4, and 17.5.0-rc-1 through 17.7.0 contain a reflected Cross-site Scripting (XSS) vulnerability, which allows an attacker to craft a malicious URL and execute arbitrary actions with the same privileges as the victim. If the victim has administrative or programming rights, those rights can be exploited to gain full access to the XWiki installation. This issue has been patched in versions 17.8.0-rc-1, 17.4.5 and 16.10.12. To workaround, the patch can be applied manually, only a single line in templates/logging_macros.vm needs to be changed, no restart is required.
Which versions are affected by CVE-2026-24128?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-web-templates. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-web-templates Maven | From 17.0.0-rc-1 | 17.4.5 |
org.xwiki.platform:xwiki-platform-web-templates Maven | From 17.0.0-rc-1 | 17.4.5 |
org.xwiki.platform:xwiki-platform-web-templates Maven | From 17.5.0-rc-1 | 17.8.0-rc-1 |
org.xwiki.platform:xwiki-platform-web-templates Maven | From 17.5.0-rc-1 | 17.8.0-rc-1 |
org.xwiki.platform:xwiki-platform-web-templates Maven | From 7.0-milestone-2 | 16.10.12 |
org.xwiki.platform:xwiki-platform-web-templates Maven | From 7.0-milestone-2 | 16.10.12 |
Products include Xwiki Xwiki, Xwiki Xwiki-Rendering.
How do I fix CVE-2026-24128?
Upgrade org.xwiki.platform:xwiki-platform-web-templates to a fixed version for your release line: 17.4.5, 17.8.0-rc-1 or 16.10.12.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-24128 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-24128 exists.
Public exploit code: 1 Nuclei template.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-wvqx-m5px-6cmp.