CVE-2026-24130 Moonraker with LDAP Enabled Allows Malicious Search Filter Injection

Low 2.7 Published Updated

Attackers can inject LDAP search filters to brute-force user IDs and attributes when LDAP is enabled, exposing sensitive directory information.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-24130?

CVE-2026-24130 is a low-severity vulnerability in Arksine moonraker, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Moonraker is a Python web server providing API access to Klipper 3D printing firmware. In versions 0.9.3 and below, instances configured with the "ldap" component enabled are vulnerable to LDAP search filter injection techniques via the login endpoint. The 401 error response message can be used to determine whether or not a search was successful, allowing for brute force methods to discover LDAP entries on the server such as user IDs and user attributes. This issue has been fixed in version 0.10.0.

Weakness: CWE-90, CWE-209

Which versions are affected by CVE-2026-24130?

3 open source packages ship an affected version, including moonraker. It affects 1 product.

PackageAffectedFixed in
moonraker PyPIAll versions0.10.0
moonraker PyPIAll versions0.10.0
moonraker PyPIAll versions0.10.0

Products include Arksine Moonraker.

How do I fix CVE-2026-24130?

Upgrade moonraker to 0.10.0 or later.

Is CVE-2026-24130 being exploited?

There is no known exploitation of CVE-2026-24130 in the wild and no public exploit code.

Sources

Also known as GHSA-3jqf-v4mv-747g, PYSEC-2026-1679.

Is CVE-2026-24130 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free