{"answers":{"affected":"3 open source packages ship an affected version, including moonraker. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-24130 in the wild and no public exploit code.","fix":"Upgrade moonraker to 0.10.0 or later.","what":"CVE-2026-24130 is a low-severity vulnerability in Arksine moonraker, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-24130 and fix it if it is affected.\n\nWhat it is: CVE-2026-24130 is a low-severity vulnerability in Arksine moonraker, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-24130 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moonraker (PyPI): affected all versions; fixed in 0.10.0\n- moonraker (PyPI): affected all versions; fixed in 0.10.0\n- moonraker (PyPI): affected all versions; fixed in 0.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-24130/ (Markdown: https://insights.sbomify.com/CVE-2026-24130/index.md)","id":"CVE-2026-24130","markdown":"https://insights.sbomify.com/CVE-2026-24130/index.md","name":"CVE-2026-24130","record":{"aliases":["GHSA-3jqf-v4mv-747g","PYSEC-2026-1679"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"3D printer API server","requires_auth":"none","summary":"Attackers can inject LDAP search filters to brute-force user IDs and attributes when LDAP is enabled, exposing sensitive directory information.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"moonraker","vendor":"arksine"}],"cvss":{"score":2.7,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-90","name":"Improper Neutralization of Special Elements used in an LDAP Query"},{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"}],"description":"Moonraker is a Python web server providing API access to Klipper 3D printing firmware. In versions 0.9.3 and below, instances configured with the \"ldap\" component enabled are vulnerable to LDAP search filter injection techniques via the login endpoint. The 401 error response message can be used to determine whether or not a search was successful, allowing for brute force methods to discover LDAP entries on the server such as user IDs and user attributes. This issue has been fixed in version 0.10.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moonraker with LDAP Enabled Allows Malicious Search Filter Injection","id":"CVE-2026-24130","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"other","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"pnpm has Path Traversal via arbitrary file permission modification","id":"CVE-2026-24131"},"packages":[{"ecosystem":"PyPI","fixed":["0.10.0"],"introduced":["0"],"last_affected":[],"package":"moonraker","purl":null,"source":"GHSA-3jqf-v4mv-747g"},{"ecosystem":"PyPI","fixed":["0.10.0"],"introduced":["0"],"last_affected":[],"package":"moonraker","purl":"pkg:pypi/moonraker","source":"GHSA-3jqf-v4mv-747g"},{"ecosystem":"PyPI","fixed":["0.10.0"],"introduced":["0"],"last_affected":[],"package":"moonraker","purl":"pkg:pypi/moonraker","source":"PYSEC-2026-1679"}],"prev":{"headline":"Runtipi is Vulnerable to Authenticated Arbitrary Remote Code Execution","id":"CVE-2026-24129"},"products":["moonraker"],"published":"2026-01-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-23","vendors":["Arksine"]},"summary":"Attackers can inject LDAP search filters to brute-force user IDs and attributes when LDAP is enabled, exposing sensitive directory information.","url":"https://insights.sbomify.com/CVE-2026-24130/"}