# CVE-2026-24130: Moonraker with LDAP Enabled Allows Malicious Search Filter Injection

> Attackers can inject LDAP search filters to brute-force user IDs and attributes when LDAP is enabled, exposing sensitive directory information.

- **Severity:** Low 2.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2026
- **Updated:** 23 Jan 2026
- **Also known as:** GHSA-3jqf-v4mv-747g, PYSEC-2026-1679

## What is CVE-2026-24130?

CVE-2026-24130 is a low-severity vulnerability in Arksine moonraker, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Moonraker is a Python web server providing API access to Klipper 3D printing firmware. In versions 0.9.3 and below, instances configured with the "ldap" component enabled are vulnerable to LDAP search filter injection techniques via the login endpoint. The 401 error response message can be used to determine whether or not a search was successful, allowing for brute force methods to discover LDAP entries on the server such as user IDs and user attributes. This issue has been fixed in version 0.10.0.

Weakness: CWE-90 (Improper Neutralization of Special Elements used in an LDAP Query), CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-24130?

3 open source packages ship an affected version, including moonraker. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moonraker` | PyPI | All versions | 0.10.0 |
| `moonraker` | PyPI | All versions | 0.10.0 |
| `moonraker` | PyPI | All versions | 0.10.0 |

Products: Arksine Moonraker.

## How do I fix CVE-2026-24130?

Upgrade moonraker to 0.10.0 or later.

## Is CVE-2026-24130 being exploited?

There is no known exploitation of CVE-2026-24130 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-24130 and fix it if it is affected.

What it is: CVE-2026-24130 is a low-severity vulnerability in Arksine moonraker, published on 22 Jan 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-24130 in the wild and no public exploit code.

Affected packages and fixed versions:
- moonraker (PyPI): affected all versions; fixed in 0.10.0
- moonraker (PyPI): affected all versions; fixed in 0.10.0
- moonraker (PyPI): affected all versions; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-24130/ (Markdown: https://insights.sbomify.com/CVE-2026-24130/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-24130
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-24130
- OSV: https://osv.dev/vulnerability/CVE-2026-24130

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-24130/
Summaries are generated and may contain mistakes; the official description above is the record.
