{"answers":{"affected":"2 open source packages ship an affected version, including pnpm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-24131 in the wild and no public exploit code.","fix":"Upgrade pnpm to 10.28.2 or later.","what":"CVE-2026-24131 is a medium-severity path traversal vulnerability in pnpm, published on 26 Jan 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-24131 and fix it if it is affected.\n\nWhat it is: CVE-2026-24131 is a medium-severity path traversal vulnerability in pnpm, published on 26 Jan 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-24131 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pnpm (npm): affected all versions; fixed in 10.28.2\n- pnpm (npm): affected all versions; fixed in 10.28.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-24131/ (Markdown: https://insights.sbomify.com/CVE-2026-24131/index.md)","id":"CVE-2026-24131","markdown":"https://insights.sbomify.com/CVE-2026-24131/index.md","name":"CVE-2026-24131","record":{"aliases":["GHSA-v253-rj99-jwpq","MINI-vrcv-2x2r-858f"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_modify","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"pnpm package manager","requires_auth":"none","summary":"A malicious npm package can exploit path traversal in pnpm to modify file permissions outside the package directory, potentially leading to privilege escalation.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pnpm","vendor":"pnpm"}],"cvss":{"score":6.7,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"pnpm is a package manager. Prior to version 10.28.2, when pnpm processes a package's `directories.bin` field, it uses `path.join()` without validating the result stays within the package root. A malicious npm package can specify `\"directories\": {\"bin\": \"../../../../tmp\"}` to escape the package directory, causing pnpm to chmod 755 files at arbitrary locations. This issue only affects Unix/Linux/macOS. Windows is not affected (`fixBin` gated by `EXECUTABLE_SHEBANG_SUPPORTED`). Version 10.28.2 contains a patch.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"pnpm has Path Traversal via arbitrary file permission modification","id":"CVE-2026-24131","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Orval Mock Generation Code Injection via const","id":"CVE-2026-24132"},"packages":[{"ecosystem":"npm","fixed":["10.28.2"],"introduced":["0"],"last_affected":[],"package":"pnpm","purl":null,"source":"GHSA-v253-rj99-jwpq"},{"ecosystem":"npm","fixed":["10.28.2"],"introduced":["0"],"last_affected":[],"package":"pnpm","purl":"pkg:npm/pnpm","source":"GHSA-v253-rj99-jwpq"}],"prev":{"headline":"Moonraker with LDAP Enabled Allows Malicious Search Filter Injection","id":"CVE-2026-24130"},"products":["pnpm"],"published":"2026-01-26","related":[{"cvss_score":8.8,"headline":"pnpm: Transitive dependency alias path traversal allows project path override via symlink replacement","id":"CVE-2026-50016","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":8.8,"headline":"pnpm: Project env lockfile can short-circuit package-manager resolution and execute lockfile-selected pnpm bytes","id":"CVE-2026-55698","kev_date_added":null,"published":"2026-06-25"},{"cvss_score":8.8,"headline":"pnpm v10+ Bypass \"Dependency lifecycle scripts execution disabled by default\"","id":"CVE-2025-69264","kev_date_added":null,"published":"2026-01-07"},{"cvss_score":8.8,"headline":"Untrusted Search Path in PNPM","id":"CVE-2022-26183","kev_date_added":null,"published":"2022-03-21"},{"cvss_score":8.2,"headline":"pnpm: Path traversal in configDependencies env lockfile allows symlink creation outside node_modules/.pnpm-config","id":"CVE-2026-59195","kev_date_added":null,"published":"2026-07-06"},{"cvss_score":7.6,"headline":"pnpm vulnerable to Command Injection via environment variable substitution","id":"CVE-2025-69262","kev_date_added":null,"published":"2026-01-07"},{"cvss_score":7.5,"headline":"pnpm: manifest identity spoof satisfies allowBuilds and runs attacker lifecycle","id":"CVE-2026-55487","kev_date_added":null,"published":"2026-06-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-01-27","vendors":["pnpm"]},"summary":"A malicious npm package can exploit path traversal in pnpm to modify file permissions outside the package directory, potentially leading to privilege escalation.","url":"https://insights.sbomify.com/CVE-2026-24131/"}